summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore164
-rw-r--r--PKGBUILD4
3 files changed, 132 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdac48879a34..a205f088a907 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = disomaster-git
pkgdesc = Library to manipulate DISC burning.
pkgver = 5.0.7.r2.g157dd8f
- pkgrel = 11
+ pkgrel = 1
url = https://github.com/linuxdeepin/disomaster
- arch = x86_64
+ arch = aarch64
groups = deepin-git
license = GPL3
makedepends = git
diff --git a/.gitignore b/.gitignore
index c6007448df06..b6e47617de11 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,37 +1,129 @@
-.*
-/*/*/
-!.travis.yml
-!.git*
-!.github/**
-pkg/
-src/
-*.xz
-*.sig
-*.asc
-*.bz2
-*.gz
-*.zip
+# Byte-compiled / optimized / DLL files
+__pycache__/
+*.py[cod]
+*$py.class
+
+# C extensions
+*.so
+
+# Distribution / packaging
+.Python
+build/
+develop-eggs/
+dist/
+downloads/
+eggs/
+.eggs/
+lib/
+lib64/
+parts/
+sdist/
+var/
+wheels/
+pip-wheel-metadata/
+share/python-wheels/
+*.egg-info/
+.installed.cfg
+*.egg
+MANIFEST
+
+# PyInstaller
+# Usually these files are written by a python script from a template
+# before PyInstaller builds the exe, so as to inject date/other infos into it.
+*.manifest
+*.spec
+
+# Installer logs
+pip-log.txt
+pip-delete-this-directory.txt
+
+# Unit test / coverage reports
+htmlcov/
+.tox/
+.nox/
+.coverage
+.coverage.*
+.cache
+nosetests.xml
+coverage.xml
+*.cover
+*.py,cover
+.hypothesis/
+.pytest_cache/
+
+# Translations
+*.mo
+*.pot
+
+# Django stuff:
*.log
-*.gem
-*.tgz
-*.tar
-*.tar.*
-*.deb
-*.rpm
-*.jar
-*.html
-trunk/
-*~
-*.sw?
-*.kate-swp
-*.orig
-*.run
-old_ver.txt
-new_ver.txt
-linux.install.pkg
-.vscode/
-*.7z
-*.xpi
-*.bin
-*.exe
-*.ttf
+local_settings.py
+db.sqlite3
+db.sqlite3-journal
+
+# Flask stuff:
+instance/
+.webassets-cache
+
+# Scrapy stuff:
+.scrapy
+
+# Sphinx documentation
+docs/_build/
+
+# PyBuilder
+target/
+
+# Jupyter Notebook
+.ipynb_checkpoints
+
+# IPython
+profile_default/
+ipython_config.py
+
+# pyenv
+.python-version
+
+# pipenv
+# According to pypa/pipenv#598, it is recommended to include Pipfile.lock in version control.
+# However, in case of collaboration, if having platform-specific dependencies or dependencies
+# having no cross-platform support, pipenv may install dependencies that don't work, or not
+# install all needed dependencies.
+#Pipfile.lock
+
+# PEP 582; used by e.g. github.com/David-OConnor/pyflow
+__pypackages__/
+
+# Celery stuff
+celerybeat-schedule
+celerybeat.pid
+
+# SageMath parsed files
+*.sage.py
+
+# Environments
+.env
+.venv
+env/
+venv/
+ENV/
+env.bak/
+venv.bak/
+
+# Spyder project settings
+.spyderproject
+.spyproject
+
+# Rope project settings
+.ropeproject
+
+# mkdocs documentation
+/site
+
+# mypy
+.mypy_cache/
+.dmypy.json
+dmypy.json
+
+# Pyre type checker
+.pyre/
diff --git a/PKGBUILD b/PKGBUILD
index f03a40193070..34ffa65edc37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
pkgname=disomaster-git
pkgver=5.0.7.r2.g157dd8f
-pkgrel=11
+pkgrel=1
pkgdesc='Library to manipulate DISC burning.'
-arch=('x86_64')
+arch=('aarch64')
url="https://github.com/linuxdeepin/disomaster"
license=('GPL3')
depends=('libisoburn')