summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD14
-rw-r--r--djgpp-pkgconfig.sh21
4 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7610140f059
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Apr 30 20:30:04 UTC 2016
+pkgbase = djgpp-pkg-config
+ pkgdesc = pkg-config wrapper for DJGPP
+ pkgver = 20160430
+ pkgrel = 1
+ url = http://pkg-config.freedesktop.org/
+ arch = any
+ license = zlib
+ depends = pkg-config
+ depends = djgpp-djcrx
+ source = djgpp-pkgconfig.sh
+ md5sums = e72377edcd717a9a101e026af237872a
+
+pkgname = djgpp-pkg-config
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f46de972b6fc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4eedd3068901
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,14 @@
+pkgname=djgpp-pkg-config
+pkgver=20160430
+pkgrel=1
+pkgdesc="pkg-config wrapper for DJGPP"
+arch=(any)
+url="http://pkg-config.freedesktop.org/"
+license=("zlib")
+depends=(pkg-config djgpp-djcrx)
+source=("djgpp-pkgconfig.sh")
+md5sums=('e72377edcd717a9a101e026af237872a')
+
+package() {
+ install -Dm755 djgpp-pkgconfig.sh "$pkgdir/usr/bin/i686-pc-msdosdjgpp-pkg-config"
+}
diff --git a/djgpp-pkgconfig.sh b/djgpp-pkgconfig.sh
new file mode 100644
index 000000000000..e4910f42e690
--- /dev/null
+++ b/djgpp-pkgconfig.sh
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+# Taken from
+# http://www.mega-nerd.com/erikd/Blog/CodeHacking/MinGWCross/pkg-config.html
+# Thanks, Erik
+
+# This file has no copyright assigned and is placed in the Public Domain.
+# No warranty is given.
+
+# When using the mingw32msvc cross compiler tools, the native Linux
+# pkg-config executable works fine as long as the default PKG_CONFIG_LIBDIR
+# is overridden.
+export PKG_CONFIG_LIBDIR=/usr/i686-pc-msdosdjgpp/lib/pkgconfig
+
+# Also want to override the standard user defined PKG_CONFIG_PATH with
+# a mingw32msvc specific one.
+# You can use PKG_CONFIG_PATH_CUSTOM to tweak pkg-config behavior further
+export PKG_CONFIG_PATH=$PKG_CONFIG_LIBDIR:$PKG_CONFIG_PATH_CUSTOM
+
+# Now just execute pkg-config with the given command line args.
+pkg-config $@