summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--linux-6.4-compat.patch14
3 files changed, 22 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 580db7a8a532..28d87706a39c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dkms-frandom
pkgdesc = A very fast random number generator kernel module (DKMS version)
pkgver = 1.2
- pkgrel = 2
+ pkgrel = 3
url = http://frandom.sourceforge.net/
arch = any
license = GPL
@@ -11,13 +11,14 @@ pkgbase = dkms-frandom
conflicts = frandom
options = !strip
source = http://www.billauer.co.il/download/frandom-1.2.tar.gz
+ source = linux-6.4-compat.patch
source = frandom.udev.patch
source = dkms.conf
source = Makefile
md5sums = 4b862b8723ff9cedcab3a7c4feeaee42
+ md5sums = 7349887f821ad71795cfdafeb41f16fb
md5sums = a41a534a4b732a6e2a0b41214fa27a1d
md5sums = b8943c145912d5da71dd84e54465bb85
md5sums = 1e94254311f05274035b5e41ff5a7a33
pkgname = dkms-frandom
-
diff --git a/PKGBUILD b/PKGBUILD
index 64739d5e0291..6cabbe043f32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Tom < reztho at archlinux dot us >
# Thanks to contributors/mantainers of frandom and dkms-nvidia packages
# since I used those packages as templates to make this one
+# Contributor: Justin Gottula <justin@jgottula.com>
pkgname=dkms-frandom
pkgver=1.2
-pkgrel=2
+pkgrel=3
pkgdesc="A very fast random number generator kernel module (DKMS version)"
arch=('any')
url="http://frandom.sourceforge.net/"
@@ -16,12 +17,14 @@ conflicts=("frandom")
options=(!strip)
_pkgname=frandom
source=("http://www.billauer.co.il/download/${_pkgname}-${pkgver}.tar.gz"
+'linux-6.4-compat.patch'
'frandom.udev.patch'
'dkms.conf'
'Makefile')
build() {
cd "$srcdir/$_pkgname-${pkgver}"
+ patch -p1 -i "$srcdir/linux-6.4-compat.patch"
patch -p1 -i "$srcdir/frandom.udev.patch"
}
@@ -34,6 +37,7 @@ package() {
}
md5sums=('4b862b8723ff9cedcab3a7c4feeaee42'
+ '7349887f821ad71795cfdafeb41f16fb'
'a41a534a4b732a6e2a0b41214fa27a1d'
'b8943c145912d5da71dd84e54465bb85'
'1e94254311f05274035b5e41ff5a7a33')
diff --git a/linux-6.4-compat.patch b/linux-6.4-compat.patch
new file mode 100644
index 000000000000..230075006f85
--- /dev/null
+++ b/linux-6.4-compat.patch
@@ -0,0 +1,14 @@
+--- original/frandom.c 2017-07-06 09:57:41.000000000 -0700
++++ modified/frandom.c 2023-10-22 16:38:32.867006422 -0700
+@@ -334,7 +334,11 @@ static int frandom_init_module(void)
+
+ erandom_seeded = 0;
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(6, 4, 0)
++ frandom_class = class_create("fastrng");
++#else
+ frandom_class = class_create(THIS_MODULE, "fastrng");
++#endif
+ if (IS_ERR(frandom_class)) {
+ result = PTR_ERR(frandom_class);
+ printk(KERN_WARNING "frandom: Failed to register class fastrng\n");