summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Revert-Make-newly-installed-modules-available-immedi.patch31
-rw-r--r--PKGBUILD19
3 files changed, 49 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed4c561c136e..deafca9038c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# 四 6月 22 13:32:02 UTC 2017
+# 三 8月 16 12:27:15 UTC 2017
pkgbase = dkms-sorted
pkgdesc = Dynamic Kernel Modules System (modified alpm hook to handle dependencies) - experimental
pkgver = 2.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dell/dkms
arch = any
license = GPL2
@@ -16,7 +16,7 @@ pkgbase = dkms-sorted
optdepends = linux-headers: build modules against the Arch kernel
optdepends = linux-lts-headers: build modules against the LTS kernel
optdepends = linux-zen-headers: build modules against the ZEN kernel
- optdepends = linux-grsec-headers: build modules against the GRSEC kernel
+ optdepends = linux-hardened-headers: build modules against the HARDENED kernel
provides = dkms
conflicts = dkms
backup = etc/dkms/framework.conf
diff --git a/0001-Revert-Make-newly-installed-modules-available-immedi.patch b/0001-Revert-Make-newly-installed-modules-available-immedi.patch
new file mode 100644
index 000000000000..582fd5ec4ab7
--- /dev/null
+++ b/0001-Revert-Make-newly-installed-modules-available-immedi.patch
@@ -0,0 +1,31 @@
+From ca38ccd38c69a096dafa51c426ee3548980d5e2a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?S=C3=A9bastien=20Luttringer?= <seblu@seblu.net>
+Date: Sat, 8 Jul 2017 15:50:55 +0200
+Subject: [PATCH] Revert "Make newly installed modules available immediately"
+To: dkms-devel@dell.com
+
+This reverts commit f5bfb12fef1fc06e56355cdba500eaa98d4e6aa8.
+---
+ dkms | 6 ------
+ 1 file changed, 6 deletions(-)
+
+diff --git a/dkms b/dkms
+index a6cedc8..3ff71d5 100644
+--- a/dkms
++++ b/dkms
+@@ -1522,12 +1522,6 @@ install_module()
+ exit 6
+ }
+
+- # Make the newly installed modules available immediately
+- find /sys/devices -name modalias -print0 | xargs -0 cat | xargs modprobe -a -b -q
+- if [ -f /lib/systemd/system/systemd-modules-load.service ]; then
+- systemctl restart systemd-modules-load.service
+- fi
+-
+ # Do remake_initrd things (save old initrd)
+ [[ $remake_initrd ]] && ! make_initrd "$kernelver" "$arch" && {
+ do_uninstall "$kernelver" "$arch"
+--
+Sébastien "Seblu" Luttringer
+
diff --git a/PKGBUILD b/PKGBUILD
index 5c6cc0fea2d2..b46f4834b722 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=dkms-sorted
pkgver=2.4.0
-pkgrel=1
+pkgrel=2
pkgdesc='Dynamic Kernel Modules System (modified alpm hook to handle dependencies) - experimental'
arch=('any')
url='https://github.com/dell/dkms'
@@ -14,23 +14,34 @@ makedepends=('git')
optdepends=('linux-headers: build modules against the Arch kernel'
'linux-lts-headers: build modules against the LTS kernel'
'linux-zen-headers: build modules against the ZEN kernel'
- 'linux-grsec-headers: build modules against the GRSEC kernel')
+ 'linux-hardened-headers: build modules against the HARDENED kernel')
backup=('etc/dkms/framework.conf')
source=("git+https://github.com/dell/dkms.git#tag=v${pkgver}"
'dkms-install.hook'
'dkms-remove.hook'
- 'alpm-hook')
+ 'alpm-hook'
+ '0001-Revert-Make-newly-installed-modules-available-immedi.patch')
provides=('dkms')
conflicts=('dkms')
sha256sums=('SKIP'
'6f2fe43f98cd3e043330e599689d3471108e5022ca7edf69ad645f609ccc33ac'
'a145a3a8880449a8bc824374b8409750f3cb7c003395fff5a8b9e5ff803c1328'
- '6ca388b4f3a65cc18a737946090ef96d56a832cc0f531bf2adbbc15545ca8cdc')
+ '6ca388b4f3a65cc18a737946090ef96d56a832cc0f531bf2adbbc15545ca8cdc'
+ '124b821b1b44ba365d915945825bcf32c1077655c3a98eb1644de56b6abfcd09')
prepare() {
cd dkms
+ # apply patch from the source array (should be a pacman feature)
+ local filename
+ for filename in "${source[@]}"; do
+ if [[ "$filename" =~ \.patch$ ]]; then
+ msg2 "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
+ fi
+ done
+
# /usr move
msg2 '/usr move patching'
for i in dkms{,_framework.conf,.bash-completion,.8,_common.postinst}; do