summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--digger.ini50
3 files changed, 3 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca9c098c6352..502dedf915b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dlang-digger
pkgdesc = A tool to build D and bisect old D versions
pkgver = 3.0.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/CyberShadow/Digger
arch = i686
arch = x86_64
@@ -11,11 +11,8 @@ pkgbase = dlang-digger
makedepends = libphobos-devel
makedepends = dtools
depends = git
- backup = etc/digger.ini
source = git+https://github.com/CyberShadow/Digger.git#tag=v3.0.6
- source = digger.ini
sha256sums = SKIP
- sha256sums = 8077a00ca2c6b41ec2a8175a2fb7114787d076627d49f9374ddbbd2394ed9e8f
pkgname = dlang-digger
diff --git a/PKGBUILD b/PKGBUILD
index 886b8b88e128..4e0c0080d63f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=dlang-digger
pkgver=3.0.6
-pkgrel=1
+pkgrel=2
pkgdesc='A tool to build D and bisect old D versions'
arch=('i686' 'x86_64')
groups=('dlang')
@@ -13,15 +13,8 @@ depends=('git')
makedepends=('dmd>=2.067.0-1' 'libphobos-devel' 'dtools')
source=(
"git+https://github.com/CyberShadow/Digger.git#tag=v${pkgver//_/-}"
- 'digger.ini'
-)
-sha256sums=(
- 'SKIP'
- '8077a00ca2c6b41ec2a8175a2fb7114787d076627d49f9374ddbbd2394ed9e8f'
-)
-backup=(
- 'etc/digger.ini'
)
+sha256sums=('SKIP')
build() {
cd "${srcdir}/Digger"
diff --git a/digger.ini b/digger.ini
deleted file mode 100644
index 922bad0d4369..000000000000
--- a/digger.ini
+++ /dev/null
@@ -1,50 +0,0 @@
-# Working directory.
-# This directory will contain all of Digger's working files:
-# the D repositories, any build prerequisites obtained
-# automatically, the current build output, and the cache, if
-# enabled.
-# Please specify an absolute path. The default is to use the
-# current directory.
-
-workDir = ~/.cache/digger/
-
-# Build cache.
-# To speed up successive runs, Digger can save the results of
-# each commit's build. The downside is that this uses up disk
-# space. The following cache engines are available:
-# - none No persistent cache.
-# - directory Store built files in a directory tree.
-# Saves some disk space by hard-linking identical
-# files.
-# - git Use a git repository (and git's deduplication /
-# compression mechanisms). Uses much less disk
-# space than "directory", but is a little slower.
-# You can periodically run "digger compact" to optimize disk
-# space used by the cache.
-
-cache = git
-
-# Build/test environment.
-# By default, Digger completely clears the environment and
-# builds a new one from scratch, to avoid potential sources
-# of contamination that can affect the D builds or test results.
-# The environment is calculated in this order:
-# 1. Clear entirely
-# 2. Build minimal environment
-# 3. Apply digger.ini settings
-# 4. Apply bisect.ini settings, if we are bisecting
-# Step 4 is only applied during the execution of the test command.
-
-[environment]
-
-# You can use %VAR% syntax to refer to the previous value of a
-# variable, or if there wasn't one, to the value from the
-# original environment (before it was cleared and rebuilt).
-
-# Examples:
-
-# Add something to PATH
-#PATH=%PATH%;C:\Tools
-
-# Import PATHEXT from the original environment
-#PATHEXT=%PATHEXT%