summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD46
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4a42dc03c11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = dmenu-rs
+ pkgdesc = The development branch of dmenu-rs. Likely has unstable features.
+ pkgver = 5.2.2.0.ged9fdd9
+ pkgrel = 1
+ url = https://github.com/Shizcow/dmenu-rs
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ makedepends = git
+ makedepends = clang
+ depends = sh
+ depends = libxinerama
+ depends = libxft
+ provides = dmenu
+ conflicts = dmenu
+ source = dmenu-rs::git+https://github.com/Shizcow/dmenu-rs.git
+ md5sums = SKIP
+
+pkgname = dmenu-rs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24fb6f9fec0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Devin Pohl <pohl.devin@gmail.com>
+
+# -------------------------------------------------------
+# PLUGINS
+# -------------------------------------------------------
+# If you'd like to compile in plugins, add the names here
+# For a list of available plugins, see the git repo
+# or run `make plugins` in the cloned repo
+PLUGINS=""
+
+_pkgname=dmenu
+pkgname=$_pkgname-rs
+pkgver=5.2.2.0.ged9fdd9
+pkgrel=1
+pkgdesc="The development branch of dmenu-rs. Likely has unstable features."
+arch=('i686' 'x86_64')
+url="https://github.com/Shizcow/dmenu-rs"
+license=('MIT')
+depends=('sh' 'libxinerama' 'libxft')
+makedepends=('rust' 'git' 'clang')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("${pkgname}::git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags --long | sed 's/-/./g'
+}
+
+prepare() (
+ cd dmenu-rs
+ git config advice.detachedHead false
+)
+
+build() (
+ cd dmenu-rs
+ git checkout develop
+ make PLUGINS="$PLUGINS"
+)
+
+package() (
+ cd $pkgname
+ make PREFIX=/usr DESTDIR="$pkgdir" PLUGINS="$PLUGINS" install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+) \ No newline at end of file