summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--dnsproxy-adguard.service10
3 files changed, 19 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50bb99ebb980..5e32be092718 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = dnsproxy-adguard
pkgdesc = Simple DNS proxy with DoH, DoT, and DNSCrypt support by AdguardTeam
pkgver = 0.19.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/AdguardTeam/dnsproxy
arch = x86_64
license = Apache
makedepends = go
makedepends = git
+ source = dnsproxy-adguard.service
source = https://github.com/AdguardTeam/dnsproxy/archive/v0.19.3.tar.gz
+ sha256sums = fe3598144edf12bcdbfe2a9e7480a96fbbb345f74631d1f9c938b2d3e46c9c90
sha256sums = 0c2be62d236a6e2b7d7db3ba1a5beaf3b926bfa282e5d595b828588574474b07
pkgname = dnsproxy-adguard
diff --git a/PKGBUILD b/PKGBUILD
index e3dbdad3e893..2f960fa990d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,16 @@
_projectname=dnsproxy
pkgname=dnsproxy-adguard
pkgver=0.19.3
-pkgrel=1
+pkgrel=2
pkgdesc="Simple DNS proxy with DoH, DoT, and DNSCrypt support by AdguardTeam"
arch=('x86_64')
url="https://github.com/AdguardTeam/dnsproxy"
license=('Apache')
-source=("https://github.com/AdguardTeam/dnsproxy/archive/v${pkgver}.tar.gz")
+source=("dnsproxy-adguard.service"
+ "https://github.com/AdguardTeam/dnsproxy/archive/v${pkgver}.tar.gz")
makedepends=("go" "git")
-sha256sums=('0c2be62d236a6e2b7d7db3ba1a5beaf3b926bfa282e5d595b828588574474b07')
+sha256sums=('fe3598144edf12bcdbfe2a9e7480a96fbbb345f74631d1f9c938b2d3e46c9c90'
+ '0c2be62d236a6e2b7d7db3ba1a5beaf3b926bfa282e5d595b828588574474b07')
build(){
cd "${srcdir}/${_projectname}-${pkgver}"
@@ -20,4 +22,5 @@ build(){
package() {
cd "${srcdir}/${_projectname}-${pkgver}"
install -Dm755 dnsproxy "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${srcdir}/dnsproxy-adguard.service" "${pkgdir}/usr/lib/systemd/system/dnsproxy-adguard.service"
}
diff --git a/dnsproxy-adguard.service b/dnsproxy-adguard.service
new file mode 100644
index 000000000000..50f23dc1782b
--- /dev/null
+++ b/dnsproxy-adguard.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Simple DNS proxy with DoH, DoT, and DNSCrypt support by AdguardTeam
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/dnsproxy-adguard -l 127.0.0.1 -p 5353 -u tls://8.8.8.8 -u tls://8.8.4.4 -u https://mozilla.cloudflare-dns.com/dns-query -u https://dns.adguard.com/dns-query -u tls://9.9.9.9 -u tls://dns.adguard.com --cache --all-servers
+Restart=always
+
+[Install]
+WantedBy=default.target