summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD27
3 files changed, 29 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b110b748c551..5dc5fd37d8b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = docker-app
pkgdesc = A utility to help make Compose files more reusable and sharable
- pkgver = 0.6.0
- pkgrel = 2
+ pkgver = 0.8.0_beta2
+ pkgrel = 1
url = https://github.com/docker/app
arch = x86_64
license = Apache
+ makedepends = go
depends = docker
- source = https://github.com/docker/app/releases/download/v0.6.0/docker-app-linux.tar.gz
- sha512sums = 75fe1d8c3df0a909c77a7985f05ea92876289a790fc781fcb535e97a463b5c9e0eb8c31c93c1508e98ae0296cd38a96e1f5a6ac52de45fd2e235423de44a0f2c
+ source = https://github.com/docker/app/archive/v0.8.0-beta2.tar.gz
+ sha512sums = 8987462f125e91355e02a34e8f82ec019975c7e7bb1fd37f52aab058dc81a7c27f781ab2c608e6739abd6caed27e08407739fc5acb346ed3fa4a5c9cf810d31b
pkgname = docker-app
diff --git a/.gitignore b/.gitignore
index 504de90a696c..cf9e6049c80e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-*.tar.gz
-*.pkg.tar
-pkg
-src
+*.tar.gz
+*.pkg.tar*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index ba4ca5e3ba04..60a50ad15eda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,31 @@
# Maintainer: David Birks <david@tellus.space>
pkgname=docker-app
-pkgver=0.6.0
-pkgrel=2
+pkgver=0.8.0_beta2
+pkgrel=1
pkgdesc="A utility to help make Compose files more reusable and sharable"
arch=(x86_64)
url="https://github.com/docker/app"
license=(Apache)
depends=('docker')
-optdepends=()
-source=(https://github.com/docker/app/releases/download/v$pkgver/$pkgname-linux.tar.gz)
-sha512sums=('75fe1d8c3df0a909c77a7985f05ea92876289a790fc781fcb535e97a463b5c9e0eb8c31c93c1508e98ae0296cd38a96e1f5a6ac52de45fd2e235423de44a0f2c')
+makedepends=('go')
+source=("https://github.com/docker/app/archive/v${pkgver//_/-}.tar.gz")
+sha512sums=('8987462f125e91355e02a34e8f82ec019975c7e7bb1fd37f52aab058dc81a7c27f781ab2c608e6739abd6caed27e08407739fc5acb346ed3fa4a5c9cf810d31b')
+
+prepare() {
+ mkdir -p gopath/src/github.com/docker
+ ln -rTsf app-${pkgver//_/-} gopath/src/github.com/docker/app
+}
+
+build() {
+ # LDFLAGS into the GOFLAGS env variable.
+ export GOFLAGS="-gcflags=all=-trimpath=${PWD} -asmflags=all=-trimpath=${PWD} -ldflags=-extldflags=-zrelro -ldflags=-extldflags=-znow"
+
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/github.com/docker/app
+ make bin/docker-app-standalone
+}
package() {
- cd $srcdir
- install -Dm755 "$pkgname-linux" "$pkgdir/usr/bin/$pkgname"
+ install -Dm 755 "$srcdir/gopath/src/github.com/docker/app/bin/$pkgname-standalone" "$pkgdir/usr/bin/$pkgname"
}