aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8352d542812b..e2389c78051c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = docker-git
pkgdesc = Pack, ship and run any application as a lightweight container.
- pkgver = r39078.b5ea9abf25
+ pkgver = r46893.a908460adb
pkgrel = 1
epoch = 1
url = https://github.com/docker/docker
@@ -40,13 +40,12 @@ pkgbase = docker-git
source = libnetwork::git+https://github.com/docker/libnetwork.git
source = tini::git+https://github.com/krallin/tini.git
source = docker.install
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = 1a8e60447794b3c4f87a2272cc9f144f
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = e9c4e8ffb92f0464a5cad4fb1a1e2a3925667ba6703dd0e5b3efc0dca6f5fcad
pkgname = docker-git
-
diff --git a/PKGBUILD b/PKGBUILD
index caa72f7b0603..f0492a46e602 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgname=docker-git
_pkgname=docker
-pkgver=r39078.b5ea9abf25
+pkgver=r46893.a908460adb
pkgrel=1
epoch=1
pkgdesc='Pack, ship and run any application as a lightweight container.'
@@ -36,13 +36,13 @@ source=('moby::git+https://github.com/moby/moby.git'
'libnetwork::git+https://github.com/docker/libnetwork.git'
'tini::git+https://github.com/krallin/tini.git'
'docker.install')
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- '1a8e60447794b3c4f87a2272cc9f144f')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'e9c4e8ffb92f0464a5cad4fb1a1e2a3925667ba6703dd0e5b3efc0dca6f5fcad')
pkgver() {
pushd "$srcdir/moby" > /dev/null
@@ -99,6 +99,7 @@ build() {
ln -sf "$srcdir/libnetwork" "$GOPATH/src/github.com/docker/"
pushd "$GOPATH/src/github.com/docker/libnetwork" >/dev/null
: "${PROXY_LDFLAGS:=-linkmode=external}"
+ export AUTO_GOPATH=1
go build -ldflags="$PROXY_LDFLAGS" -o ./bin/docker-proxy 'github.com/docker/libnetwork/cmd/proxy'
popd >/dev/null