summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.CHANGELOG50
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
3 files changed, 58 insertions, 8 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index 21ce7b623ae2..c8bfd64cb638 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,5 +1,55 @@
# Changelog
+## v0.34.0
+
+*Mar 31, 2022*
+
+- French translation (#1440): The UI is now available in French!
+ Thanks to @jgirardet.
+- Link Items (#528): Link items together directly (without using
+ custom fields) and see all related items quickly on the search page.
+- Import mails recursively (#1260): The scanmailbox task can now go
+ through folders recursively. Thanks to @Moerfi666 and @seijikun.
+- Fulltext search via PostgreSQL (#424): Another backend for full-text
+ search was added that is backed by PostgreSQL's text search feature.
+ You can now choose between SOLR and PostgreSQL for fulltext search.
+- More file backends (#1379): Next to storing the files in the
+ database, you can now choose to store them in a S3 compatible
+ storage or use the filesystem directly.
+- Flat zip upload (#1366): An option has been added to the upload
+ metadata that will unpack zip files and process each entry
+ separately (instead of treating a zip file as a single item).
+- Fix to upload large files (#1339): Uploaded files are not loaded
+ entirely into memory allowing to upload large files.
+- Fix previously published db migration (#1454, #1436): Unfortunately,
+ there was an db migration in the last release that caused problems
+ on some installations. A fix for this migration has been added.
+- Fix build to run on windows (#1449, #1461): Building docspell on
+ windows has been improved by @arittner.
+
+For some of the new features, you need the new version of
+[dsc](https://github.com/docspell/dsc).
+
+### Rest API Changes
+
+- adds routes to clone file repositories and the integrity check
+- adds routes to support linking items
+- `ScanMailboxSettings` has a new flag `scanRecursively`
+- `ItemDetail` and `ItemLight` contain a new field to transport
+ related/linked items
+- `ItemUploadMeta` has a new flag to specify whether zip files should
+ be treated as a container only, and be "flattened" into the list of
+ uploaded files
+
+### Configuration Changes
+
+- rest server only: added options to tune the http server
+- joex only: adds a file integrity check to the regular house keeping tasks
+- configuration for postgresql based full-text search
+- extend `files` config adding the different storage backends for
+ files
+
+
## v0.33.0
*Mar 6, 2022*
diff --git a/.SRCINFO b/.SRCINFO
index 4b6a5aa4a31b..0bed92406893 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = docspell
pkgdesc = Assists in organizing your piles of documents, resulting from scanners, e-mails and other sources with miminal effort.
- pkgver = 0.33.0
+ pkgver = 0.34.0
pkgrel = 1
url = https://docspell.org/
changelog = .CHANGELOG
arch = any
groups = docspell
license = GPL3
- source = docspell-0.33.0-restserver.zip::https://github.com/eikek/docspell/releases/download/v0.33.0/docspell-restserver-0.33.0.zip
- source = docspell-0.33.0-joex.zip::https://github.com/eikek/docspell/releases/download/v0.33.0/docspell-joex-0.33.0.zip
+ source = docspell-0.34.0-restserver.zip::https://github.com/eikek/docspell/releases/download/v0.34.0/docspell-restserver-0.34.0.zip
+ source = docspell-0.34.0-joex.zip::https://github.com/eikek/docspell/releases/download/v0.34.0/docspell-joex-0.34.0.zip
source = docspell-joex.sh
source = docspell-restserver.sh
source = docspell-joex.service
source = docspell-restserver.service
source = docspell.sysusers
source = docspell.tmpfiles
- sha512sums = 114f56adba03e76ced44fe03454bdb0aecefc544460832e9bdb0cbc0cd27afc85516d861ffbcd79f9f30e66231ff828f0aa07cb12ae29c52dc0001d568e52eaa
- sha512sums = 4de052ef3c46bce350d258925fa961ec84436eea3880789dae0fd2780d5d0f021255cc1f74fa97b94ef6c562cb2d6e87c69522dc078c727fe2700e201e5852ad
+ sha512sums = d5f04691cceeab40297486c5a63814bdebbcc16141320ed209aeadccd71fe628095108e78f45c8cc09227750566737f0ddaf575af539b29b2d4e0cc86f88df1f
+ sha512sums = 39656b9518d407a812a04b2385a49db3f27e758788e9b2e883ad5c77a98a0f37ad066e466a68c36f4dafddd2285ad3b2f8e808c2ea31a3f745de40bf4aafaa72
sha512sums = 6ab8b24eb76f02b68e4fa4194b8771ef4f57c8375b34bf7bf914563528e347ea127beb5547e432910911d4fd15982cccdd1df50aeb76058129b909824ce49093
sha512sums = 0b8b08f47f1cb46a3bfc16df4b0574cebfb4a851562d134fcba3c4bf80fb011443499a549c3a04480456c048346d09f36fbcbc9d792810001c9c8b370d3926a8
sha512sums = c1a7a9cb942413d0febb083554a15ded0ead5c7124624f0ec5fe43d3bc73a1637f89bc27f7b6e0bbdbd0d886799e5331beb5f45f476db70b69ae17c0d803f004
diff --git a/PKGBUILD b/PKGBUILD
index 41ac00d50316..1a19f1165372 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgname=(
'docspell-restserver'
# 'firefox-extension-docspell'
)
-pkgver=0.33.0
+pkgver=0.34.0
pkgrel=1
changelog=.CHANGELOG
arch=('any')
@@ -25,8 +25,8 @@ source=("$pkgbase-$pkgver-restserver.zip::https://github.com/eikek/$pkgbase/rele
"${pkgname[1]}.service"
"$pkgbase.sysusers"
"$pkgbase.tmpfiles")
-sha512sums=('114f56adba03e76ced44fe03454bdb0aecefc544460832e9bdb0cbc0cd27afc85516d861ffbcd79f9f30e66231ff828f0aa07cb12ae29c52dc0001d568e52eaa'
- '4de052ef3c46bce350d258925fa961ec84436eea3880789dae0fd2780d5d0f021255cc1f74fa97b94ef6c562cb2d6e87c69522dc078c727fe2700e201e5852ad'
+sha512sums=('d5f04691cceeab40297486c5a63814bdebbcc16141320ed209aeadccd71fe628095108e78f45c8cc09227750566737f0ddaf575af539b29b2d4e0cc86f88df1f'
+ '39656b9518d407a812a04b2385a49db3f27e758788e9b2e883ad5c77a98a0f37ad066e466a68c36f4dafddd2285ad3b2f8e808c2ea31a3f745de40bf4aafaa72'
'6ab8b24eb76f02b68e4fa4194b8771ef4f57c8375b34bf7bf914563528e347ea127beb5547e432910911d4fd15982cccdd1df50aeb76058129b909824ce49093'
'0b8b08f47f1cb46a3bfc16df4b0574cebfb4a851562d134fcba3c4bf80fb011443499a549c3a04480456c048346d09f36fbcbc9d792810001c9c8b370d3926a8'
'c1a7a9cb942413d0febb083554a15ded0ead5c7124624f0ec5fe43d3bc73a1637f89bc27f7b6e0bbdbd0d886799e5331beb5f45f476db70b69ae17c0d803f004'