summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.CHANGELOG36
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
3 files changed, 45 insertions, 9 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index cb54ec1b619b..8706de46af98 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,5 +1,41 @@
# Changelog
+## v0.31.0
+
+*Jan 16, 2022*
+
+- Bookmark queries and use it in searches. (#1175) Also the periodic
+ query form is updated to allow using a bookmarks.
+- Customize message for periodic queries (#1258). You can now add your
+ own sentence to the beginning of the message notifying you for a
+ list of items.
+- Allow to configure a priority for Gotify notifications (#1277)
+- Improve handling tags (#960). When choosing a tag by the dropdown
+ the catgory is shown next to a tag and the options can be
+ constrainted by clicking a category bubble.
+- Fix timezone in docker image (#1234)
+- Fix adding high-dpi images that would cause an out-of-memory error
+ when generating previews (#1183).
+- Fix tearing down and initializing pubsub table to allow changing app
+ ids (#1251)
+- Fix switching between tile and list view when "full width" preview
+ is enabled (#1261)
+- Disable "group by month" if there are no groups (#1255)
+- Fix deleting periodic queries (button was not working) (#1257)
+
+### Rest API Changes
+
+- new routes for managing bookmarks
+- added routes for client settings to be separated between user and
+ collective, the previous endpoint now returns a merged json
+- add a priority value to gotify settings
+- add bookmark value to periodic query settings
+
+### Configuration Changes
+
+None.
+
+
## v0.30.1
*Dec 22, 2021*
diff --git a/.SRCINFO b/.SRCINFO
index a6c06eb5f969..abbbcb97c550 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = docspell
pkgdesc = Assists in organizing your piles of documents, resulting from scanners, e-mails and other sources with miminal effort.
- pkgver = 0.30.1
+ pkgver = 0.31.0
pkgrel = 1
url = https://docspell.org/
changelog = .CHANGELOG
arch = any
groups = docspell
license = GPL3
- source = docspell-0.30.1-restserver.zip::https://github.com/eikek/docspell/releases/download/v0.30.1/docspell-restserver-0.30.1.zip
- source = docspell-0.30.1-joex.zip::https://github.com/eikek/docspell/releases/download/v0.30.1/docspell-joex-0.30.1.zip
+ source = docspell-0.31.0-restserver.zip::https://github.com/eikek/docspell/releases/download/v0.31.0/docspell-restserver-0.31.0.zip
+ source = docspell-0.31.0-joex.zip::https://github.com/eikek/docspell/releases/download/v0.31.0/docspell-joex-0.31.0.zip
source = docspell-joex.sh
source = docspell-restserver.sh
source = docspell-joex.service
source = docspell-restserver.service
source = docspell.sysusers
source = docspell.tmpfiles
- sha512sums = 6e69b1553b2891f64e57b7743c9cb9e474e759023bb5f05ae4417cee730fba3d4b5a2d8a857e7ba9dc4267cb352bab3bcdb1cc30f6204d9ccfdd48c72910c255
- sha512sums = 15b8cf23c50a8544b3e364934e6f91b9a3c3aefb98803c2fa1451d4f1919d63884818fdf5892b3f805e5e7234130d8d329deb84c5ac48681c0f82ca54f2d7e1f
+ sha512sums = 0501b6e6ef991c277e03f48f7800f05bb4b65c376721236c30d74bbb1b239d5f15761989e0b4c994f865ea9e5a874532637d1405f81e41e1056c5ee9cc8e2cbd
+ sha512sums = b5f92969d0882898e141b33ebd5de4cd096ddc982624af0e684093ec9f510000476ab7caf96985a7dbd1403fda2b55538784adc4d6d8e0d9ef5081ec836cdbb3
sha512sums = 6ab8b24eb76f02b68e4fa4194b8771ef4f57c8375b34bf7bf914563528e347ea127beb5547e432910911d4fd15982cccdd1df50aeb76058129b909824ce49093
sha512sums = 0b8b08f47f1cb46a3bfc16df4b0574cebfb4a851562d134fcba3c4bf80fb011443499a549c3a04480456c048346d09f36fbcbc9d792810001c9c8b370d3926a8
sha512sums = c1a7a9cb942413d0febb083554a15ded0ead5c7124624f0ec5fe43d3bc73a1637f89bc27f7b6e0bbdbd0d886799e5331beb5f45f476db70b69ae17c0d803f004
diff --git a/PKGBUILD b/PKGBUILD
index 7732d93321a3..5721a28bbb73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lucki <https://aur.archlinux.org/account/Lucki>
# shellcheck shell=bash
-# shellcheck disable=SC2034,2154
+# shellcheck disable=2034,2154
pkgbase=docspell
pkgname=(
@@ -8,7 +8,7 @@ pkgname=(
'docspell-restserver'
# 'firefox-extension-docspell'
)
-pkgver=0.30.1
+pkgver=0.31.0
pkgrel=1
changelog=.CHANGELOG
arch=('any')
@@ -25,8 +25,8 @@ source=("$pkgbase-$pkgver-restserver.zip::https://github.com/eikek/$pkgbase/rele
"${pkgname[1]}.service"
"$pkgbase.sysusers"
"$pkgbase.tmpfiles")
-sha512sums=('6e69b1553b2891f64e57b7743c9cb9e474e759023bb5f05ae4417cee730fba3d4b5a2d8a857e7ba9dc4267cb352bab3bcdb1cc30f6204d9ccfdd48c72910c255'
- '15b8cf23c50a8544b3e364934e6f91b9a3c3aefb98803c2fa1451d4f1919d63884818fdf5892b3f805e5e7234130d8d329deb84c5ac48681c0f82ca54f2d7e1f'
+sha512sums=('0501b6e6ef991c277e03f48f7800f05bb4b65c376721236c30d74bbb1b239d5f15761989e0b4c994f865ea9e5a874532637d1405f81e41e1056c5ee9cc8e2cbd'
+ 'b5f92969d0882898e141b33ebd5de4cd096ddc982624af0e684093ec9f510000476ab7caf96985a7dbd1403fda2b55538784adc4d6d8e0d9ef5081ec836cdbb3'
'6ab8b24eb76f02b68e4fa4194b8771ef4f57c8375b34bf7bf914563528e347ea127beb5547e432910911d4fd15982cccdd1df50aeb76058129b909824ce49093'
'0b8b08f47f1cb46a3bfc16df4b0574cebfb4a851562d134fcba3c4bf80fb011443499a549c3a04480456c048346d09f36fbcbc9d792810001c9c8b370d3926a8'
'c1a7a9cb942413d0febb083554a15ded0ead5c7124624f0ec5fe43d3bc73a1637f89bc27f7b6e0bbdbd0d886799e5331beb5f45f476db70b69ae17c0d803f004'