summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.CHANGELOG36
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
3 files changed, 45 insertions, 10 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index a0f78edcd1fb..cb54ec1b619b 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,5 +1,39 @@
# Changelog
+## v0.30.1
+
+*Dec 22, 2021*
+
+Bug fix release for #1229: notification mails could not be sent.
+
+
+## v0.30.0
+
+*Dec 21, 2021*
+
+- Add a list view for items, allowing to toggle between tile and list
+ view (#526)
+- Generic notification system: It is a start. A few events are
+ available with the idea to add more when needed. Get notified about
+ certain events via gotify, matrix or e-mail. A generic periodic
+ query has been added (in addition to the notify-due-items task).
+ (#848, #1174)
+- Update stanford-corenlp and add Spanish to the supported language
+ set for NLP and Hungarian to the standard set of languages.
+- Fix to update job execution count when a job is canceled (#1182)
+- Change the log format to [logfmt](https://www.brandur.org/logfmt)
+ and remove all ansi color sequences
+
+### Rest API Changes
+
+- added new routes to manage notification channels and hooks
+- added new routes for the generic periodic query task
+
+### Configuration Changes
+
+None.
+
+
## v0.29.0
*Nov 18, 2021*
@@ -13,7 +47,7 @@
- Improve scanmailbox form (#1147)
- Improve input of an e-mail address (#987)
- Fix e-mail import for certain files (#1140)
-- FIx uploading files with non-ascii filenames (#991)
+- Fix uploading files with non-ascii filenames (#991)
### Rest API Changes
diff --git a/.SRCINFO b/.SRCINFO
index 88a8df28c1a0..a6c06eb5f969 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = docspell
pkgdesc = Assists in organizing your piles of documents, resulting from scanners, e-mails and other sources with miminal effort.
- pkgver = 0.29.0
+ pkgver = 0.30.1
pkgrel = 1
url = https://docspell.org/
changelog = .CHANGELOG
arch = any
groups = docspell
license = GPL3
- source = docspell-0.29.0-restserver.zip::https://github.com/eikek/docspell/releases/download/v0.29.0/docspell-restserver-0.29.0.zip
- source = docspell-0.29.0-joex.zip::https://github.com/eikek/docspell/releases/download/v0.29.0/docspell-joex-0.29.0.zip
+ source = docspell-0.30.1-restserver.zip::https://github.com/eikek/docspell/releases/download/v0.30.1/docspell-restserver-0.30.1.zip
+ source = docspell-0.30.1-joex.zip::https://github.com/eikek/docspell/releases/download/v0.30.1/docspell-joex-0.30.1.zip
source = docspell-joex.sh
source = docspell-restserver.sh
source = docspell-joex.service
source = docspell-restserver.service
source = docspell.sysusers
source = docspell.tmpfiles
- sha512sums = 392a10d66414c56901a95a814b997d212af58e1ca606d7bf6e872c1b0631009465e3fa7f627347e164004740fd11cec0e4cc0456a3b4386e5d80046f074fd209
- sha512sums = b532b2b39f2fb338273d8083c3d0ad5c34c4cfe3f39dacb856614b1503689bcdd5ab5a0957a0a71ee486fd3f01f0632bb81dd0792ee346824244017044586e74
+ sha512sums = 6e69b1553b2891f64e57b7743c9cb9e474e759023bb5f05ae4417cee730fba3d4b5a2d8a857e7ba9dc4267cb352bab3bcdb1cc30f6204d9ccfdd48c72910c255
+ sha512sums = 15b8cf23c50a8544b3e364934e6f91b9a3c3aefb98803c2fa1451d4f1919d63884818fdf5892b3f805e5e7234130d8d329deb84c5ac48681c0f82ca54f2d7e1f
sha512sums = 6ab8b24eb76f02b68e4fa4194b8771ef4f57c8375b34bf7bf914563528e347ea127beb5547e432910911d4fd15982cccdd1df50aeb76058129b909824ce49093
sha512sums = 0b8b08f47f1cb46a3bfc16df4b0574cebfb4a851562d134fcba3c4bf80fb011443499a549c3a04480456c048346d09f36fbcbc9d792810001c9c8b370d3926a8
sha512sums = c1a7a9cb942413d0febb083554a15ded0ead5c7124624f0ec5fe43d3bc73a1637f89bc27f7b6e0bbdbd0d886799e5331beb5f45f476db70b69ae17c0d803f004
diff --git a/PKGBUILD b/PKGBUILD
index a2f3418d24e4..7732d93321a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Lucki <https://aur.archlinux.org/account/Lucki>
-# shellcheck disable=SC2034,2154,2148
+# shellcheck shell=bash
+# shellcheck disable=SC2034,2154
pkgbase=docspell
pkgname=(
@@ -7,7 +8,7 @@ pkgname=(
'docspell-restserver'
# 'firefox-extension-docspell'
)
-pkgver=0.29.0
+pkgver=0.30.1
pkgrel=1
changelog=.CHANGELOG
arch=('any')
@@ -24,8 +25,8 @@ source=("$pkgbase-$pkgver-restserver.zip::https://github.com/eikek/$pkgbase/rele
"${pkgname[1]}.service"
"$pkgbase.sysusers"
"$pkgbase.tmpfiles")
-sha512sums=('392a10d66414c56901a95a814b997d212af58e1ca606d7bf6e872c1b0631009465e3fa7f627347e164004740fd11cec0e4cc0456a3b4386e5d80046f074fd209'
- 'b532b2b39f2fb338273d8083c3d0ad5c34c4cfe3f39dacb856614b1503689bcdd5ab5a0957a0a71ee486fd3f01f0632bb81dd0792ee346824244017044586e74'
+sha512sums=('6e69b1553b2891f64e57b7743c9cb9e474e759023bb5f05ae4417cee730fba3d4b5a2d8a857e7ba9dc4267cb352bab3bcdb1cc30f6204d9ccfdd48c72910c255'
+ '15b8cf23c50a8544b3e364934e6f91b9a3c3aefb98803c2fa1451d4f1919d63884818fdf5892b3f805e5e7234130d8d329deb84c5ac48681c0f82ca54f2d7e1f'
'6ab8b24eb76f02b68e4fa4194b8771ef4f57c8375b34bf7bf914563528e347ea127beb5547e432910911d4fd15982cccdd1df50aeb76058129b909824ce49093'
'0b8b08f47f1cb46a3bfc16df4b0574cebfb4a851562d134fcba3c4bf80fb011443499a549c3a04480456c048346d09f36fbcbc9d792810001c9c8b370d3926a8'
'c1a7a9cb942413d0febb083554a15ded0ead5c7124624f0ec5fe43d3bc73a1637f89bc27f7b6e0bbdbd0d886799e5331beb5f45f476db70b69ae17c0d803f004'