summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.CHANGELOG65
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
3 files changed, 73 insertions, 8 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index e93e35b23629..21ce7b623ae2 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,5 +1,70 @@
# Changelog
+## v0.33.0
+
+*Mar 6, 2022*
+
+- Refactor file identifiers, as preparation for different file storage
+ backends (#1380)
+ - **PLEASE NOTE** this release contains a DB migration that changes
+ all file identifiers in the database. It is really very much
+ recommended to do a backup of the database *before* updating!
+- Allow background tasks to return results that are published via events (#1362)
+ - the task for processing files returns now data (item id, name,
+ extracted text, tags etc) that is included in the `JobDone` event
+ data
+- Users can specify a time zone in user settings (#1062)
+ - the time zone is used when formatting dates in the web ui
+ - the time zone is used for calendar events of periodic tasks; you
+ need to save each periodic task again in order to pass a different
+ timezone
+ - should you have calendar events in the config file, you can add a
+ time zone at the end
+ - if not specified, it will default to UTC as before
+- Improve item selection (#1422)
+ - selecting items was possible before, but only ephemeral in the list view
+ - it is now stored globally and kept until you explicitely clear the selection
+ - items can be selected in detail view and the search menu shows an
+ entry to quickly see all items currently selected
+ - makes it easier to select a bunch of documents for sharing/bookmarking etc
+- Change logging format and backend
+ - The logging format has changed again from logfmt to the "classic" one
+ - the configuration allows to use logfmt, json or two "classic" formats
+ - logback has been removed! If you used a custom `logback.xml`
+ before, I'm sorry this is not possible anymore. There are two
+ settings in the config file for now to control logging:
+ `logging.minimum-level` and `logging.format`.
+- Pdf preview not updated (#1210)
+ - some browsers (e.g. safari and some mobile browsers) don't update
+ the ui when the `src` attribute of the `embed` element changes
+ - for the "fallback view", an `iframe` is now used - thus for mobile
+ it should work now. Safari on desktop would require to change the
+ respective setting
+- Several ui improvements
+ - More cards per row for large screens (#1401)
+ - more space below direction dropdown (#1400)
+ - fix input field save-while-typing (#1340, #1299)
+ - improves detail view on small screens (#1420)
+ - sort tags by group and then name (#1396)
+ - fix bug presenting an empty tag category in search menu (#1402)
+ - wrap long text in dashboard tables (#1357)
+ - typo fixes (#1387, #1433)
+- Remove tools package from release (#1421)
+ - the tools package doesn't contain general useful stuff anymore and
+ is thus removed from the release packaging. The code is still
+ there, and can be packaged manually
+
+### Rest API Changes
+
+None.
+
+### Configuration Changes
+
+- add `logging.format` and `logging.minimum-level`
+- change default values for calendar events to explicitely show that
+ they are in UTC (the value itself is not changed)
+
+
## v0.32.0
*Feb 06, 2022*
diff --git a/.SRCINFO b/.SRCINFO
index 44c0ec146b65..4b6a5aa4a31b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = docspell
pkgdesc = Assists in organizing your piles of documents, resulting from scanners, e-mails and other sources with miminal effort.
- pkgver = 0.32.0
+ pkgver = 0.33.0
pkgrel = 1
url = https://docspell.org/
changelog = .CHANGELOG
arch = any
groups = docspell
license = GPL3
- source = docspell-0.32.0-restserver.zip::https://github.com/eikek/docspell/releases/download/v0.32.0/docspell-restserver-0.32.0.zip
- source = docspell-0.32.0-joex.zip::https://github.com/eikek/docspell/releases/download/v0.32.0/docspell-joex-0.32.0.zip
+ source = docspell-0.33.0-restserver.zip::https://github.com/eikek/docspell/releases/download/v0.33.0/docspell-restserver-0.33.0.zip
+ source = docspell-0.33.0-joex.zip::https://github.com/eikek/docspell/releases/download/v0.33.0/docspell-joex-0.33.0.zip
source = docspell-joex.sh
source = docspell-restserver.sh
source = docspell-joex.service
source = docspell-restserver.service
source = docspell.sysusers
source = docspell.tmpfiles
- sha512sums = 84a64a246567b2a8f7df41b2d3407f1c355424cc0583ed9a31aca42eb0da3ef40c6f2fb8d6982939a8d26383694499768d3c8efa5ff0caba21dd599c17652125
- sha512sums = 5eeeb4a9c03f8b7c8184b593ef2e402d5597df9b0a1b7bcdf770e9969be37c4a0d4f3d8732380d797c23be39c96f08a8b215c586f598c7de266b4e9ede1276a2
+ sha512sums = 114f56adba03e76ced44fe03454bdb0aecefc544460832e9bdb0cbc0cd27afc85516d861ffbcd79f9f30e66231ff828f0aa07cb12ae29c52dc0001d568e52eaa
+ sha512sums = 4de052ef3c46bce350d258925fa961ec84436eea3880789dae0fd2780d5d0f021255cc1f74fa97b94ef6c562cb2d6e87c69522dc078c727fe2700e201e5852ad
sha512sums = 6ab8b24eb76f02b68e4fa4194b8771ef4f57c8375b34bf7bf914563528e347ea127beb5547e432910911d4fd15982cccdd1df50aeb76058129b909824ce49093
sha512sums = 0b8b08f47f1cb46a3bfc16df4b0574cebfb4a851562d134fcba3c4bf80fb011443499a549c3a04480456c048346d09f36fbcbc9d792810001c9c8b370d3926a8
sha512sums = c1a7a9cb942413d0febb083554a15ded0ead5c7124624f0ec5fe43d3bc73a1637f89bc27f7b6e0bbdbd0d886799e5331beb5f45f476db70b69ae17c0d803f004
diff --git a/PKGBUILD b/PKGBUILD
index 23425335ca11..41ac00d50316 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgname=(
'docspell-restserver'
# 'firefox-extension-docspell'
)
-pkgver=0.32.0
+pkgver=0.33.0
pkgrel=1
changelog=.CHANGELOG
arch=('any')
@@ -25,8 +25,8 @@ source=("$pkgbase-$pkgver-restserver.zip::https://github.com/eikek/$pkgbase/rele
"${pkgname[1]}.service"
"$pkgbase.sysusers"
"$pkgbase.tmpfiles")
-sha512sums=('84a64a246567b2a8f7df41b2d3407f1c355424cc0583ed9a31aca42eb0da3ef40c6f2fb8d6982939a8d26383694499768d3c8efa5ff0caba21dd599c17652125'
- '5eeeb4a9c03f8b7c8184b593ef2e402d5597df9b0a1b7bcdf770e9969be37c4a0d4f3d8732380d797c23be39c96f08a8b215c586f598c7de266b4e9ede1276a2'
+sha512sums=('114f56adba03e76ced44fe03454bdb0aecefc544460832e9bdb0cbc0cd27afc85516d861ffbcd79f9f30e66231ff828f0aa07cb12ae29c52dc0001d568e52eaa'
+ '4de052ef3c46bce350d258925fa961ec84436eea3880789dae0fd2780d5d0f021255cc1f74fa97b94ef6c562cb2d6e87c69522dc078c727fe2700e201e5852ad'
'6ab8b24eb76f02b68e4fa4194b8771ef4f57c8375b34bf7bf914563528e347ea127beb5547e432910911d4fd15982cccdd1df50aeb76058129b909824ce49093'
'0b8b08f47f1cb46a3bfc16df4b0574cebfb4a851562d134fcba3c4bf80fb011443499a549c3a04480456c048346d09f36fbcbc9d792810001c9c8b370d3926a8'
'c1a7a9cb942413d0febb083554a15ded0ead5c7124624f0ec5fe43d3bc73a1637f89bc27f7b6e0bbdbd0d886799e5331beb5f45f476db70b69ae17c0d803f004'