summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.CHANGELOG164
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD8
3 files changed, 174 insertions, 12 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index 41940f73b7bd..9d374f391f4f 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,5 +1,167 @@
# Changelog
+## v0.25.1
+
+*Jul 29, 2021*
+
+- Fix solr fulltext search by adding the new japanese content field
+
+The SOLR fulltext search is broken in 0.25.0, so this is a fixup
+release.
+
+## v0.25.0
+
+*Jul 29, 2021*
+
+- Introducing a new CLI tool (#345) that replaces all the shell
+ scripts from the `tools/` directory! https://github.com/docspell/dsc
+- UI changes:
+ - year separators are now more prominent (#950)
+ - fixes a bug in the item counter in detail view when an item is
+ deleted (#920)
+ - German translation improvements (#901)
+ - The number of selected files is shown in upload page (#896)
+- The created date of an item can now be used in queries (#925, #958)
+- Setting tags api has been improved (#955)
+- Task for converting pdfs is now behind the admin secret (#949)
+- Task for generating preview images is now behind the admin secret (#915)
+- respond with 404 when the source-id is not correct (#931)
+- Update of core libraries (#890)
+- Add Japanese to the list of document languages. Thanks @wallace11
+ for helping out (#948, #962)
+- Fix setting the folder from metadata when processing a file and
+ allow to specifiy it by name or id (#940)
+- Fixes docspell config file in docker-compose setup (#909)
+- Fixes selecting the next job in the job executor (#898)
+- Fixes a bug that prevents uploading more than one file at once
+ (#938)
+
+### Rest API Changes
+
+- Removed `sec/item/convertallpdfs` endpoint in favor for new
+ `admin/attachments/convertallpdfs` endpoint which is now an admin
+ task
+- Removed `sec/collective/previews` endpoint, in favor for new
+ `admin/attachments/generatePreviews` endpoint which is now an admin
+ task to generate previews for all files. The now removed enpoint did
+ this only for one collective.
+- `/sec/item/{id}/tags`: Setting tags to an item (replacing existing
+ tags) has been changed to allow tags to be specified as names or ids
+- `/sec/item/{id}/tagsremove`: Added a route to remove tags for a
+ single item
+
+### Configuration Changes
+
+None.
+
+
+## v0.24.0
+
+*Jun 18, 2021*
+
+This time a translation of the Web-UI in German is included and the
+docker build was overhauled. The releases are now build and tested
+using Java 11.
+
+- Rework Docker setup. Images are now provided for different
+ architectures and have a new home now (see below). The images are
+ now built via a github-action from the official packages of each
+ release. (#635, #643, #840, #687)
+- Translation of the UI into German (thanks to @monnypython for proof
+ reading and applying lots of corrections!) (#292, #683, #870)
+- Improve migration of SOLR (#604)
+ - The information whether solr has been setup, is now stored inside
+ SOLR. This means when upgrading Docspell, all data will be
+ re-indexed.
+- Add `--exclude` and `--include` options to the `consumedir.sh`
+ script (#885)
+- Improved documenation of the http api (#874)
+- Removed unused libraries in the final packages to reduce file size a
+ bit (#841)
+- Bug: Searching by tag category was broken when using upper case
+ letters (#849)
+- Bug: when adding a boolean custom field, it must be applied
+ immediatly (#842)
+- Bug: when entering a space in a dropdown the menu closes (#863)
+- Bug: Some scripts didn't work with earlier versions of `jq` (#851)
+- Bug: The source form was broken in that it didn't load the language
+ correctly (#877)
+- Bug: Tag category options were wrongly populated when narrowing tags
+ via a search (#880)
+
+### Breaking Changes
+
+#### Java 11
+
+Not really a breaking change. Docspell is now build and tested using
+Java 11. Docspell has a small amount of Java source code. This is
+compiled using Java 11 but to target Java 8 JVMs. So it still can run
+under Java 8. However, it is recommended to use at least Java 11 to
+run Docspell.
+
+
+#### Docker Images
+
+The docker images are now pushed to the
+[docspell](https://hub.docker.com/u/docspell) organization at
+docker-hub! So the images are now:
+
+- `docspell/restserver`
+- `docspell/joex`
+- `docspell/tools`
+
+Tags: images are tagged with two floating tags: `nightly` and
+`latest`. The `nightly` tag always points to the latest development
+state (the master branch). The `latest` tag points to the latest
+release. Each release is also tagged with its version number, like
+`v0.24.0`.
+
+The images changed slightly in that there is no assumption on where
+the config file is placed. Now you need to pass the docspell config
+file explicitely when using the images.
+
+Multiarch: Images are now build for `amd64`, `arm64` and `armv7`.
+
+The consumedir is being replaced by the more generic `docspell/tools`
+image which contains all the scripts from the `tools/` section. That
+means it has no special entrypoint for the consumedir script anymore.
+The polling functionality is now provided by the consumedir script.
+And the docker-compose file needs now to specify the complete command
+arguments. This makes it much more flexible to use.
+
+This allows to use this image to run all the other tool scripts, too.
+The scripts are in PATH inside the image and prefixed by `ds-`, so for
+example `ds-consumedir` or `ds-export-files` etc.
+
+#### Docker Compose
+
+The docker-compose setup is now at `docker/docker-compose`. Please
+look at the new [compose
+file](https://github.com/eikek/docspell/blob/master/docker/docker-compose/docker-compose.yml)
+and do the corresponding changes at yours. Especially the consumedir
+container changed significantly. Then due to the fact that the config
+file must be given explicitely, you need to add this argument to each
+docspell component (restserver and joex) via a `command` section (see
+the compose file referenced above).
+
+The `.envrc` has been cleaned from some settings. Since the config
+files is mounted into the image, you can just edit this file instead.
+The only settings left in the .envrc file are those that need to be
+available in the docker-compose file and the application. If some
+settings need to be duplicated for joex and restserver, you can use
+the builtin variable resolution mechanism for this. An example is
+provided in the new config file.
+
+### Configuration Changes
+
+None.
+
+
+### Rest API Changes
+
+None.
+
+
## v0.23.0
*May 29, 2021*
@@ -812,7 +974,7 @@ improvements for processing files.
upload the file into memory for nothing if something fails (e.g. the
source doesn't exist)
- Re-process files. A
- [route](https://docspell.org/openapi/docspell-openapi.html#api-Item-secItemItemIdReprocessPost)
+ [route](https://docspell.org/openapi/docspell-openapi.html#operation/sec-item-start-reprocess)
has been added that submits files for re-processing. It is possible
to re-process some files of an item or all. There is no UI for this
for now. You'd need to run `curl` or something manually to trigger
diff --git a/.SRCINFO b/.SRCINFO
index 2369d45be8d3..7ef8c27edfa2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = docspell
pkgdesc = Assists in organizing your piles of documents, resulting from scanners, e-mails and other sources with miminal effort.
- pkgver = 0.24.0
+ pkgver = 0.25.1
pkgrel = 1
url = https://docspell.org/
changelog = .CHANGELOG
@@ -8,18 +8,18 @@ pkgbase = docspell
groups = docspell
license = GPL3
makedepends = python
- source = docspell-0.24.0-restserver.zip::https://github.com/eikek/docspell/releases/download/v0.24.0/docspell-restserver-0.24.0.zip
- source = docspell-0.24.0-joex.zip::https://github.com/eikek/docspell/releases/download/v0.24.0/docspell-joex-0.24.0.zip
- source = docspell-0.24.0-tools.zip::https://github.com/eikek/docspell/releases/download/v0.24.0/docspell-tools-0.24.0.zip
+ source = docspell-0.25.1-restserver.zip::https://github.com/eikek/docspell/releases/download/v0.25.1/docspell-restserver-0.25.1.zip
+ source = docspell-0.25.1-joex.zip::https://github.com/eikek/docspell/releases/download/v0.25.1/docspell-joex-0.25.1.zip
+ source = docspell-0.25.1-tools.zip::https://github.com/eikek/docspell/releases/download/v0.25.1/docspell-tools-0.25.1.zip
source = docspell-joex.sh
source = docspell-restserver.sh
source = docspell-joex.service
source = docspell-restserver.service
source = docspell.sysusers
source = docspell.tmpfiles
- sha512sums = c07461c803ad79f71a54162000e53451ab7d8c9c58e80cf6003c5bd33fcc9974daf2b21a9f335d77377c6b0db0798fe2813097a8a1e08aa11e95b5503e858980
- sha512sums = d29dbfbb5cd4959381b41b4eacb6a7b5fa3b30c6693f18fe8af827ada002783421edf5f28ae83db8b8d7dbd3f91908f28f5b56ab11050ca815b5a76c44e5be80
- sha512sums = a7be6c0e8f4a930ffac84d6a3835c576096342e722ba8043739e364a897c6adbca868b332c50fbd61aa9a60948a352e7721822ddc754dca614ebf28946f2a467
+ sha512sums = 7300038077244dde9ddf5a8702112ae9e8fef4604a19d088193206a30987b9085542ff8de0fd14583a15520bb3577a984b8e84a3e0a545ee9acbcd173cf3aeb3
+ sha512sums = bc7bb401c9abca4180e3ae8febdcb8d9f90d9a2e5b30df08396d8c950224886a289202448deb352252239131f5ab608f4b832977cf7558489efb5005451e3868
+ sha512sums = fbcbc0e2a3d4cafd00357257f6bb7c5fe80154defad883d37ec08c59deee1a125bf653eac5ccd020b8db6d8a1296da86c197d7f160da1a709121ad728d56502f
sha512sums = 6ab8b24eb76f02b68e4fa4194b8771ef4f57c8375b34bf7bf914563528e347ea127beb5547e432910911d4fd15982cccdd1df50aeb76058129b909824ce49093
sha512sums = 0b8b08f47f1cb46a3bfc16df4b0574cebfb4a851562d134fcba3c4bf80fb011443499a549c3a04480456c048346d09f36fbcbc9d792810001c9c8b370d3926a8
sha512sums = c1a7a9cb942413d0febb083554a15ded0ead5c7124624f0ec5fe43d3bc73a1637f89bc27f7b6e0bbdbd0d886799e5331beb5f45f476db70b69ae17c0d803f004
diff --git a/PKGBUILD b/PKGBUILD
index ce6561a3284e..21815aeaed0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=docspell
pkgname=('docspell-joex' 'docspell-restserver' 'docspell-tools')
-pkgver=0.24.0
+pkgver=0.25.1
pkgrel=1
changelog=.CHANGELOG
arch=('any')
@@ -20,9 +20,9 @@ source=("$pkgbase-$pkgver-restserver.zip::https://github.com/eikek/$pkgbase/rele
"${pkgname[1]}.service"
"$pkgbase.sysusers"
"$pkgbase.tmpfiles")
-sha512sums=('c07461c803ad79f71a54162000e53451ab7d8c9c58e80cf6003c5bd33fcc9974daf2b21a9f335d77377c6b0db0798fe2813097a8a1e08aa11e95b5503e858980'
- 'd29dbfbb5cd4959381b41b4eacb6a7b5fa3b30c6693f18fe8af827ada002783421edf5f28ae83db8b8d7dbd3f91908f28f5b56ab11050ca815b5a76c44e5be80'
- 'a7be6c0e8f4a930ffac84d6a3835c576096342e722ba8043739e364a897c6adbca868b332c50fbd61aa9a60948a352e7721822ddc754dca614ebf28946f2a467'
+sha512sums=('7300038077244dde9ddf5a8702112ae9e8fef4604a19d088193206a30987b9085542ff8de0fd14583a15520bb3577a984b8e84a3e0a545ee9acbcd173cf3aeb3'
+ 'bc7bb401c9abca4180e3ae8febdcb8d9f90d9a2e5b30df08396d8c950224886a289202448deb352252239131f5ab608f4b832977cf7558489efb5005451e3868'
+ 'fbcbc0e2a3d4cafd00357257f6bb7c5fe80154defad883d37ec08c59deee1a125bf653eac5ccd020b8db6d8a1296da86c197d7f160da1a709121ad728d56502f'
'6ab8b24eb76f02b68e4fa4194b8771ef4f57c8375b34bf7bf914563528e347ea127beb5547e432910911d4fd15982cccdd1df50aeb76058129b909824ce49093'
'0b8b08f47f1cb46a3bfc16df4b0574cebfb4a851562d134fcba3c4bf80fb011443499a549c3a04480456c048346d09f36fbcbc9d792810001c9c8b370d3926a8'
'c1a7a9cb942413d0febb083554a15ded0ead5c7124624f0ec5fe43d3bc73a1637f89bc27f7b6e0bbdbd0d886799e5331beb5f45f476db70b69ae17c0d803f004'