summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--fixing-boost.patch12
3 files changed, 8 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d66a04521f2..9fa0b6fc0435 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dogecoin-qt
pkgdesc = Cryptocurrency
- pkgver = 1.8.2
- pkgrel = 2
+ pkgver = 1.10.0
+ pkgrel = 1
url = http://dogecoin.com/
install = dogecoin.install
arch = x86_64
@@ -23,12 +23,10 @@ pkgbase = dogecoin-qt
depends = openssl
depends = db
provides = dogecoin-qt
- source = https://github.com/dogecoin/dogecoin/archive/v1.8.2.tar.gz
+ source = https://github.com/dogecoin/dogecoin/archive/v1.10.0.tar.gz
source = dogecoin.desktop
- source = fixing-boost.patch
- sha256sums = 87060dfe6d9770f8af17c447120cb6a059bbd84687dfd6a1f0787c9d75d75d9e
+ sha256sums = 2c279a7ee425b3706ce635c74a27fd813ac3605a37f6f13e63775ec311f90f7c
sha256sums = 04d41773462ad6609658e291d22b15cd8d58b8eb5e4391a80cd1dae75e7df0e6
- sha256sums = 3b335f979bc54d5c8760c84192a3b1224e0fa0d7afaa2fb806c4a3b777c2bded
pkgname = dogecoin-qt
diff --git a/PKGBUILD b/PKGBUILD
index df3a01fb0a61..773b042a87aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=dogecoin-qt
_binname=dogecoin
-pkgver=1.8.2
-pkgrel=2
+pkgver=1.10.0
+pkgrel=1
pkgdesc="Cryptocurrency"
arch=('x86_64' 'i686')
url="http://dogecoin.com/"
@@ -15,18 +15,11 @@ depends=('miniupnpc' 'boost-libs' 'protobuf' 'openssl' 'db')
makedepends=('boost' 'gcc' 'make' 'git' 'qt4' 'miniupnpc' 'boost-libs' 'protobuf' 'openssl' 'db')
source=("https://github.com/dogecoin/dogecoin/archive/v${pkgver}.tar.gz"
"dogecoin.desktop"
- "fixing-boost.patch"
)
install=dogecoin.install
-sha256sums=('87060dfe6d9770f8af17c447120cb6a059bbd84687dfd6a1f0787c9d75d75d9e'
- '04d41773462ad6609658e291d22b15cd8d58b8eb5e4391a80cd1dae75e7df0e6'
- '3b335f979bc54d5c8760c84192a3b1224e0fa0d7afaa2fb806c4a3b777c2bded')
-
-prepare() {
- cd "${srcdir}/dogecoin-$pkgver/"
- patch -p1 -i $srcdir/fixing-boost.patch
-}
+sha256sums=('2c279a7ee425b3706ce635c74a27fd813ac3605a37f6f13e63775ec311f90f7c'
+ '04d41773462ad6609658e291d22b15cd8d58b8eb5e4391a80cd1dae75e7df0e6')
build() {
cd "${srcdir}/dogecoin-$pkgver/"
diff --git a/fixing-boost.patch b/fixing-boost.patch
deleted file mode 100644
index ec5223cf20d6..000000000000
--- a/fixing-boost.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -aur dogecoin-1.8.2.pristine/src/rpcrawtransaction.cpp dogecoin-1.8.2.new/src/rpcrawtransaction.cpp
---- dogecoin-1.8.2.pristine/src/rpcrawtransaction.cpp 2015-01-17 19:22:54.000000000 +0100
-+++ dogecoin-1.8.2.new/src/rpcrawtransaction.cpp 2015-05-24 10:57:09.750066113 +0200
-@@ -296,7 +296,7 @@
- CTxDestination address;
- if (ExtractDestination(pk, address))
- {
-- const CScriptID& hash = boost::get<const CScriptID&>(address);
-+ const CScriptID& hash = boost::relaxed_get<const CScriptID&>(address);
- CScript redeemScript;
- if (pwalletMain->GetCScript(hash, redeemScript))
- entry.push_back(Pair("redeemScript", HexStr(redeemScript.begin(), redeemScript.end())));