summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
-rw-r--r--crontab_calls.patch4
3 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25c78f63f3b8..3196f3ed1c59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dokku
pkgdesc = Docker-powered PaaS that helps build and manage the lifecycle of applications
- pkgver = 0.28.4
+ pkgver = 0.29.0
pkgrel = 1
url = https://github.com/dokku/dokku
install = dokku.install
@@ -11,6 +11,7 @@ pkgbase = dokku
depends = cpio
depends = curl
depends = docker
+ depends = docker-compose
depends = docker-image-labeler
depends = dos2unix
depends = git
@@ -31,14 +32,14 @@ pkgbase = dokku
depends = sudo
depends = sshcommand
depends = unzip
- source = https://github.com/dokku/dokku/archive/v0.28.4.zip
+ source = https://github.com/dokku/dokku/archive/v0.29.0.zip
source = dokku.install
source = crontab_calls.patch
source = systemd_calls.patch
source = LICENSE
- sha256sums = a2a46f32e565ff6aff863288a457ab125a0eb22feb8b857d00c892162175b476
+ sha256sums = 3bb545a12f4648ee291637744d6f50fa14bcc3e731da9edd1e1f63fd87abfbea
sha256sums = 5b3e99b6be28f8c68e024d9127992bcd49c758566a6ecaa15f9788a411eab0f0
- sha256sums = dda85c90106e68b5478679fb2a5b8b37a786d188703abd255e079bdada36a9c0
+ sha256sums = 55993df7e243de7a009da05f802cb0b306dc67aa181a510f6825a8b2874b2397
sha256sums = c600fefea1c93e9f94192741adc679fb0a05674775d3677954f10db4e09205c6
sha256sums = b1ac2fed5ac269fb7bbf651a3d37ef5fd56d2c33320e17cb6e23a22a93f5c046
diff --git a/PKGBUILD b/PKGBUILD
index 78784f892e4b..fc6ca349dd5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fabien LEFEBVRE <contact@d1ceward.com>
pkgname=dokku
-pkgver=0.28.4
+pkgver=0.29.0
pkgrel=1
pkgdesc='Docker-powered PaaS that helps build and manage the lifecycle of applications'
arch=('any')
@@ -13,6 +13,7 @@ depends=(
'cpio'
'curl'
'docker'
+ 'docker-compose'
'docker-image-labeler'
'dos2unix'
'git'
@@ -39,9 +40,9 @@ source=("${url}/archive/v${pkgver}.zip"
"crontab_calls.patch"
"systemd_calls.patch"
"LICENSE")
-sha256sums=('a2a46f32e565ff6aff863288a457ab125a0eb22feb8b857d00c892162175b476'
+sha256sums=('3bb545a12f4648ee291637744d6f50fa14bcc3e731da9edd1e1f63fd87abfbea'
'5b3e99b6be28f8c68e024d9127992bcd49c758566a6ecaa15f9788a411eab0f0'
- 'dda85c90106e68b5478679fb2a5b8b37a786d188703abd255e079bdada36a9c0'
+ '55993df7e243de7a009da05f802cb0b306dc67aa181a510f6825a8b2874b2397'
'c600fefea1c93e9f94192741adc679fb0a05674775d3677954f10db4e09205c6'
'b1ac2fed5ac269fb7bbf651a3d37ef5fd56d2c33320e17cb6e23a22a93f5c046')
install="${pkgname}.install"
diff --git a/crontab_calls.patch b/crontab_calls.patch
index e965a9a26c93..ad27e4d4d1f2 100644
--- a/crontab_calls.patch
+++ b/crontab_calls.patch
@@ -1,5 +1,5 @@
---- a/plugins/cron/functions.go 2022-03-08 17:40:53.000000000 +0100
-+++ b/plugins/cron/functions.go 2022-03-08 22:37:11.883706200 +0100
+--- a/plugins/cron/functions.go 2022-12-09 00:42:16.085851600 +0100
++++ b/plugins/cron/functions.go 2022-12-09 00:44:28.535851600 +0100
@@ -81,13 +81,13 @@
}