summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--dokku.install8
3 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 856e71898ecf..e35413231d3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dokku
pkgdesc = Docker-powered PaaS that helps build and manage the lifecycle of applications
- pkgver = 0.23.2
+ pkgver = 0.23.4
pkgrel = 1
url = https://github.com/dokku/dokku
install = dokku.install
@@ -21,11 +21,11 @@ pkgbase = dokku
depends = procfile-util
depends = rsyslog
depends = sshcommand
- source = https://github.com/dokku/dokku/archive/v0.23.2.zip
+ source = https://github.com/dokku/dokku/archive/v0.23.4.zip
source = dokku.install
source = LICENSE
- sha256sums = e1db9db187bca7032c4c62a30083377a014d64e8e34c3f9a4c49b5d6e90d382a
- sha256sums = d6887859d5c43febf6591c32d8b4706797a28ce308050b62871bc3f7f9df418e
+ sha256sums = ad385e60b60904bcc3aadf481b3930e201109c008af892a6f7cdee75c2786a58
+ sha256sums = dd7ca19339e18f8434ca74faeb994ae8446cb3ccf020e558eaa340ad1f72effe
sha256sums = b1ac2fed5ac269fb7bbf651a3d37ef5fd56d2c33320e17cb6e23a22a93f5c046
pkgname = dokku
diff --git a/PKGBUILD b/PKGBUILD
index f28b3e595e2b..005302d3d527 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fabien LEFEBVRE <contact@d1ceward.com>
pkgname=dokku
-pkgver=0.23.2
+pkgver=0.23.4
pkgrel=1
pkgdesc='Docker-powered PaaS that helps build and manage the lifecycle of applications'
arch=('any')
@@ -27,8 +27,8 @@ depends=(
source=("https://github.com/dokku/dokku/archive/v$pkgver.zip"
"$pkgname.install"
"LICENSE")
-sha256sums=('e1db9db187bca7032c4c62a30083377a014d64e8e34c3f9a4c49b5d6e90d382a'
- 'd6887859d5c43febf6591c32d8b4706797a28ce308050b62871bc3f7f9df418e'
+sha256sums=('ad385e60b60904bcc3aadf481b3930e201109c008af892a6f7cdee75c2786a58'
+ 'dd7ca19339e18f8434ca74faeb994ae8446cb3ccf020e558eaa340ad1f72effe'
'b1ac2fed5ac269fb7bbf651a3d37ef5fd56d2c33320e17cb6e23a22a93f5c046')
install="$pkgname.install"
diff --git a/dokku.install b/dokku.install
index facbbe276c45..0aa7163f8118 100644
--- a/dokku.install
+++ b/dokku.install
@@ -14,6 +14,12 @@ setup-user() {
chown -R dokku:dokku "${DOKKU_ROOT}/.ssh" "${DOKKU_ROOT}/.dokkurc"
}
+setup-storage() {
+ echo "Setting up storage directories"
+ mkdir -p "${DOKKU_LIB_ROOT}/data" "${DOKKU_LIB_ROOT}/data/storage"
+ chown dokku:dokku "${DOKKU_LIB_ROOT}/data"
+}
+
setup-plugins() {
echo "Setting up plugin directories"
mkdir -p "${DOKKU_LIB_ROOT}/core-plugins/available" "${DOKKU_LIB_ROOT}/plugins/available"
@@ -43,6 +49,7 @@ setup-plugins() {
chown dokku:dokku -R "${DOKKU_LIB_ROOT}/plugins" "${DOKKU_LIB_ROOT}/core-plugins"
echo "Install all core plugins"
+ dokku plugin:install-dependencies --core
dokku plugin:install --core
rm -f /etc/update-motd.d/99-dokku
@@ -60,6 +67,7 @@ setup-sshcommand() {
post_install() {
setup-user
+ setup-storage
setup-plugins
setup-sshcommand