summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
-rw-r--r--crontab_calls.patch27
-rw-r--r--dokku.install2
4 files changed, 42 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a1e94ced75d..6adda7a022db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dokku
pkgdesc = Docker-powered PaaS that helps build and manage the lifecycle of applications
pkgver = 0.24.10
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dokku/dokku
install = dokku.install
arch = any
@@ -16,6 +16,7 @@ pkgbase = dokku
depends = git
depends = go
depends = gliderlabs-sigil
+ depends = inetutils
depends = herokuish
depends = jq
depends = man-db
@@ -32,9 +33,11 @@ pkgbase = dokku
depends = unzip
source = https://github.com/dokku/dokku/archive/v0.24.10.zip
source = dokku.install
+ source = crontab_calls.patch
source = LICENSE
sha256sums = bed55e2f3d0b037a62599a528dace16083e528428277d8ab03a25041d8a7a2eb
- sha256sums = 3e58b518ce747483f01371a903cc66ea346076c87512cff52da0bd7932760538
+ sha256sums = dd7ca19339e18f8434ca74faeb994ae8446cb3ccf020e558eaa340ad1f72effe
+ sha256sums = 88fae4d0578b9badaa91d1d4771952b4c7560ba2f56f4eda990034078a44431e
sha256sums = b1ac2fed5ac269fb7bbf651a3d37ef5fd56d2c33320e17cb6e23a22a93f5c046
pkgname = dokku
diff --git a/PKGBUILD b/PKGBUILD
index df8244370dce..f8991600e830 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=dokku
pkgver=0.24.10
-pkgrel=1
+pkgrel=2
pkgdesc='Docker-powered PaaS that helps build and manage the lifecycle of applications'
arch=('any')
url='https://github.com/dokku/dokku'
@@ -18,6 +18,7 @@ depends=(
'git'
'go'
'gliderlabs-sigil'
+ 'inetutils'
'herokuish'
'jq'
'man-db'
@@ -35,9 +36,11 @@ depends=(
)
source=("https://github.com/dokku/dokku/archive/v$pkgver.zip"
"$pkgname.install"
+ "crontab_calls.patch"
"LICENSE")
sha256sums=('bed55e2f3d0b037a62599a528dace16083e528428277d8ab03a25041d8a7a2eb'
- '3e58b518ce747483f01371a903cc66ea346076c87512cff52da0bd7932760538'
+ 'dd7ca19339e18f8434ca74faeb994ae8446cb3ccf020e558eaa340ad1f72effe'
+ '88fae4d0578b9badaa91d1d4771952b4c7560ba2f56f4eda990034078a44431e'
'b1ac2fed5ac269fb7bbf651a3d37ef5fd56d2c33320e17cb6e23a22a93f5c046')
install="$pkgname.install"
@@ -51,6 +54,9 @@ build() {
cd "$pkgname-$pkgver"
+ # Fix issue on crontab calls with arch linux cron implementation
+ patch -p1 -i "${srcdir}/crontab_calls.patch"
+
# Add .core and build go plugins
for plugin in plugins/*; do
if [ -e "$plugin/Makefile" ]; then make -C $plugin build; fi
@@ -72,6 +78,6 @@ package() {
mkdir -p "$pkgdir/var/lib/dokku/core-plugins/available"
cp -R "$srcdir/$pkgname-$pkgver/plugins/." "$pkgdir/var/lib/dokku/core-plugins/available"
- # Version
+ # Version
echo $pkgver > "$pkgdir/var/lib/dokku/VERSION"
}
diff --git a/crontab_calls.patch b/crontab_calls.patch
new file mode 100644
index 000000000000..b02796523747
--- /dev/null
+++ b/crontab_calls.patch
@@ -0,0 +1,27 @@
+--- a/plugins/cron/functions.go 2021-06-07 02:25:18.000000000 +0200
++++ b/plugins/cron/functions.go 2021-07-12 15:58:47.292094682 +0200
+@@ -81,13 +81,13 @@
+ }
+
+ func deleteCrontab() error {
+- command := common.NewShellCmd("crontab -l -u dokku")
++ command := common.NewShellCmd("crontab -l")
+ command.ShowOutput = false
+ if !command.Execute() {
+ return nil
+ }
+
+- command = common.NewShellCmd("crontab -r -u dokku")
++ command = common.NewShellCmd("crontab -r")
+ command.ShowOutput = false
+ out, err := command.CombinedOutput()
+ if err != nil {
+@@ -163,7 +163,7 @@
+ return fmt.Errorf("Unable to template out schedule file: %v", err)
+ }
+
+- command := common.NewShellCmd(fmt.Sprintf("crontab -u dokku %s", tmpFile.Name()))
++ command := common.NewShellCmd(fmt.Sprintf("crontab %s", tmpFile.Name()))
+ command.ShowOutput = false
+ out, err := command.CombinedOutput()
+ if err != nil {
diff --git a/dokku.install b/dokku.install
index 94b277150080..0aa7163f8118 100644
--- a/dokku.install
+++ b/dokku.install
@@ -76,7 +76,7 @@ post_install() {
cp "${DOKKU_LIB_ROOT}/VERSION" "${DOKKU_ROOT}/VERSION"
echo "Update hostname"
- cp /etc/hostname "${DOKKU_ROOT}/HOSTNAME"
+ hostname -f > "${DOKKU_ROOT}/HOSTNAME"
echo "
Please add your ssh pubkey like: