summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
-rwxr-xr-xhostname3
3 files changed, 7 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45176fad92ed..3264b59ef279 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dokku
pkgdesc = Docker-powered PaaS that helps build and manage the lifecycle of applications
- pkgver = 0.27.10
+ pkgver = 0.28.0
pkgrel = 1
url = https://github.com/dokku/dokku
install = dokku.install
@@ -17,6 +17,7 @@ pkgbase = dokku
depends = go
depends = gliderlabs-sigil
depends = herokuish
+ depends = inetutils
depends = jq
depends = man-db
depends = netrc
@@ -30,18 +31,15 @@ pkgbase = dokku
depends = sudo
depends = sshcommand
depends = unzip
- conflicts = inetutils
- source = https://github.com/dokku/dokku/archive/v0.27.10.zip
+ source = https://github.com/dokku/dokku/archive/v0.28.0.zip
source = dokku.install
source = crontab_calls.patch
source = systemd_calls.patch
- source = hostname
source = LICENSE
- sha256sums = fa66855b974eb8a89074a8a674a176af90984e9e3eaa62120baa374ea5238c8d
+ sha256sums = 5a9a54bdd46a00c41cad21f96aef1b055dea731424670d445390e43ea32f4135
sha256sums = 5b3e99b6be28f8c68e024d9127992bcd49c758566a6ecaa15f9788a411eab0f0
sha256sums = dda85c90106e68b5478679fb2a5b8b37a786d188703abd255e079bdada36a9c0
sha256sums = c600fefea1c93e9f94192741adc679fb0a05674775d3677954f10db4e09205c6
- sha256sums = 3f4223dec09dde4148e0b6f4e9474ec3d2a9064bf070d637967324e103615ba6
sha256sums = b1ac2fed5ac269fb7bbf651a3d37ef5fd56d2c33320e17cb6e23a22a93f5c046
pkgname = dokku
diff --git a/PKGBUILD b/PKGBUILD
index 338318eac031..51dd9b5453d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fabien LEFEBVRE <contact@d1ceward.com>
pkgname=dokku
-pkgver=0.27.10
+pkgver=0.28.0
pkgrel=1
pkgdesc='Docker-powered PaaS that helps build and manage the lifecycle of applications'
arch=('any')
@@ -19,6 +19,7 @@ depends=(
'go'
'gliderlabs-sigil'
'herokuish'
+ 'inetutils'
'jq'
'man-db'
'netrc'
@@ -37,15 +38,12 @@ source=("${url}/archive/v${pkgver}.zip"
"${pkgname}.install"
"crontab_calls.patch"
"systemd_calls.patch"
- "hostname"
"LICENSE")
-sha256sums=('fa66855b974eb8a89074a8a674a176af90984e9e3eaa62120baa374ea5238c8d'
+sha256sums=('5a9a54bdd46a00c41cad21f96aef1b055dea731424670d445390e43ea32f4135'
'5b3e99b6be28f8c68e024d9127992bcd49c758566a6ecaa15f9788a411eab0f0'
'dda85c90106e68b5478679fb2a5b8b37a786d188703abd255e079bdada36a9c0'
'c600fefea1c93e9f94192741adc679fb0a05674775d3677954f10db4e09205c6'
- '3f4223dec09dde4148e0b6f4e9474ec3d2a9064bf070d637967324e103615ba6'
'b1ac2fed5ac269fb7bbf651a3d37ef5fd56d2c33320e17cb6e23a22a93f5c046')
-conflicts=('inetutils')
install="${pkgname}.install"
build() {
@@ -81,7 +79,6 @@ package() {
# Install executable and license
install -Dm755 "${pkgname}-${pkgver}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm755 hostname "${pkgdir}/usr/bin/hostname"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# Move all files in place
diff --git a/hostname b/hostname
deleted file mode 100755
index 03706f0541f4..000000000000
--- a/hostname
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/usr/bin/env bash
-
-/usr/bin/uname -n