aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--README.md42
3 files changed, 14 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f34e3f1798bd..aab4b6114ece 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dom4-server
pkgdesc = Configure and run Dominions 4 as a headless server
- pkgver = 1.1.0
+ pkgver = 1.1.1
pkgrel = 1
url = http://www.illwinter.com/dom4/
install = dom4-server.install
diff --git a/PKGBUILD b/PKGBUILD
index c3191742ee56..3904bf37ec17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Dominions 4 Server Configuration
# Maintainer: Dian Fay <dian.m.fay@gmail.com>
pkgname=dom4-server
-pkgver=1.1.0
+pkgver=1.1.1
pkgrel=1
pkgdesc="Configure and run Dominions 4 as a headless server"
arch=("x86_64")
diff --git a/README.md b/README.md
index d1f3a2f8ef2b..4e1206ea6bf3 100644
--- a/README.md
+++ b/README.md
@@ -4,55 +4,37 @@
Install this package (`dom4-server`) using your AUR package manager of choice, or `makepkg`.
-Dominions 4 must be installed to /opt/Dominions4. If you already have it installed elsewhere and don't want to mess around with permissions, it's easiest to just copy it.
-
-If you installed it from the Steam GUI:
+### Application
```bash
-sudo cp -R ~/.local/share/Steam/steamapps/common/Dominions4 /opt
+dom4 install
```
-If you installed it via SteamCMD (see below for directions if you're starting from scratch with no GUI):
-
-```bash
-sudo cp -R ~/Steam/steamapps/common/Dominions4 /opt
-```
-
-If you can't find it at either of those locations, try `locate dom4.sh` (if you *just* installed Dominions 4, `sudo updatedb` first). This should output one line with the full path and filename of `dom4.sh`. `sudo cp -R` the path, excluding the filename.
-
-### License Key
-
-Your install directory must have a `dom4key` file present containing your Dominions 4 license key. If the file does not already exist, you can create it using the license information from Steam.
+You will need to enter your Steam user ID, password, and Dominions 4 license key when prompted. SteamCMD may ask you to authenticate through Steam Guard.
### Network
-You can use whatever port number you like between 1024 and 65535. Make sure you don't have anything else running on that port.
+Choose a port number between 1024 and 65535 and make sure you don't have anything else running on that port. Specify this number when configuring games.
If your computer is behind a router you will need to make sure the port is forwarded. It is also helpful to configure a static IP address so the routing stays consistent. Consult your router documentation for instructions.
## Game Configuration
-Your game configuration is stored in key=value format in a properties file. Copy `default.properties` to a safe location and edit as needed. `mapfile` should reference the filename of a map either in the same location as the properties file or in *your* `~/dominions4/maps` directory. Once ready:
+```bash
+dom4 config mygame
+```
+
+Edit the file as desired and save. The `mapfile` should reference a file either in the current directory or in *your* `~/dominions4/maps` directory. Once you have a game configured:
-1. `sudo dom4 config mygame.properties` loads your config into the server and sets the current game name.
1. `sudo systemctl start dom4-server` starts the server in pretender upload mode.
1. If `uploadmaxp` or `uploadtime` are set in your configuration, you're done: the game will start automatically when the appropriate limit is reached.
-1. Once everyone has uploaded their pretenders, `sudo dom4 ready` sets the game start flag. You can `sudo dom4 ready mygame` to specify a game to host regardless of what was last configured.
+1. Once everyone has uploaded their pretenders, `dom4 ready` sets the game start flag. You can `dom4 ready mygame` to specify a game to host regardless of what was last configured.
1. Restart the server using `sudo systemctl restart dom4-server` to begin the game.
You may also want to `sudo systemctl enable dom4-server` in order to start the server automatically after reboots.
-Note that only one game may be served at a time. If you run `dom4 config` with a config file when a game has already been set up, it will ask if you want to host the new game instead. The previous config file will be preserved, unless the new one has the same name.
+Note that only one game may be served at a time. If you configure or ready a new game, any previously active configuration will be preserved unless you are directly overwriting it.
### Deleting Games
-`sudo dom4 delete mygame` removes the properties file and save directory. Maps are not removed.
-
-## SteamCMD
-
-Here's how to download and install Dominions 4 from Steam without needing to let X or a monitor anywhere near your computer:
-
-1. Install `steamcmd` using your AUR package manager of choice.
-1. Run `steamcmd`.
-1. `login your_user_name`. Supply the password if asked.
-1. `app_update 259060`. Once the download finishes, you're all set.
+`dom4 delete mygame` removes the properties file and save directory. Maps are not removed.