summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
-rw-r--r--domoticz.install2
-rw-r--r--domoticz.service6
5 files changed, 34 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dff36a65235a..53d194ae80b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = domoticz
pkgdesc = Web based home automation
- pkgver = 2020.2
- pkgrel = 4
+ pkgver = 2023.2
+ pkgrel = 1
url = https://www.domoticz.com
install = domoticz.install
arch = i686
@@ -9,11 +9,10 @@ pkgbase = domoticz
arch = arm
arch = armv6h
arch = armv7h
- license = GPL-3.0
+ license = GPL3
makedepends = git
makedepends = cmake
makedepends = boost
- makedepends = python
depends = libusb-compat
depends = curl
depends = sqlite
@@ -24,10 +23,9 @@ pkgbase = domoticz
depends = mosquitto
depends = jsoncpp
depends = python
- source = https://github.com/domoticz/domoticz/archive/2020.2.tar.gz
+ source = domoticz-2023.2.tar.gz::https://github.com/domoticz/domoticz/archive/2023.2.tar.gz
source = domoticz.service
- md5sums = fd383a13d13d0976c72f332d6db1d24e
- md5sums = c13a3f5d04142587d159820156a6223f
+ sha256sums = 32bcf49df8c80c470352e63004a82d9601b90ccf406096099656250a4515ac28
+ sha256sums = 908e2848731eef27928f87936f94ff3df280901559fcf5f4754b1a8139e4a38a
pkgname = domoticz
-
diff --git a/.gitignore b/.gitignore
index 58c0555641dc..d506f8e1b90f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,8 @@
+*.log
*.tar.gz
*.tar.xz
+*.tar.zst
*.tgz
*.txt
-src/
pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index a9fb2511744a..9061bdf62fc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
-# Maintainer : Martin Dratva <raquacontact+aur at gmail dot com>
+# Maintainer : Arvid Norlander <VorpalBlade (at) users DOT noreply DOT github DOT com>
+# Contributor : Martin Dratva <raquacontact+aur at gmail dot com>
# Contributor : Dimitris Kiziridis <ragouel at outlook dot com>
# Contributor : Jaron Viƫtor <thulinma@thulinma.com>
# Contributor : Jameson Pugh <imntreal@gmail.com>
pkgname=domoticz
-pkgver=2020.2
-pkgrel=4
+pkgver=2023.2
+pkgrel=1
pkgdesc="Web based home automation"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url='https://www.domoticz.com'
-license=('GPL-3.0')
+license=('GPL3')
depends=('libusb-compat'
'curl'
'sqlite'
@@ -22,17 +23,27 @@ depends=('libusb-compat'
'python')
makedepends=('git'
'cmake'
- 'boost'
- 'python')
+ 'boost')
install='domoticz.install'
-source=("https://github.com/domoticz/domoticz/archive/${pkgver}.tar.gz"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/domoticz/domoticz/archive/${pkgver}.tar.gz"
'domoticz.service')
-md5sums=('fd383a13d13d0976c72f332d6db1d24e'
- 'c13a3f5d04142587d159820156a6223f')
+sha256sums=('32bcf49df8c80c470352e63004a82d9601b90ccf406096099656250a4515ac28'
+ '908e2848731eef27928f87936f94ff3df280901559fcf5f4754b1a8139e4a38a')
prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ #local p
+ #for p in "${srcdir}"/*.patch; do
+ # patch --forward --strip=1 --input="${p}"
+ #done
+
mkdir -p "${srcdir}/${pkgname}-${pkgver}/build"
+}
+
+build() {
cd "${srcdir}/${pkgname}-${pkgver}/build"
+
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/opt/domoticz \
-DUSE_STATIC_OPENZWAVE=NO \
@@ -45,15 +56,13 @@ prepare() {
-DUSE_OPENSSL_STATIC=NO \
-DUSE_PYTHON=YES \
..
-}
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}/build"
make
}
package() {
cd ${srcdir}/${pkgname}-${pkgver}/build
+
make DESTDIR=${pkgdir} install
chmod o+r "${pkgdir}/opt/domoticz/updatedomo"
mkdir -p "${pkgdir}/usr/lib/systemd/system"
diff --git a/domoticz.install b/domoticz.install
index 2e16f59b7750..58a50acb3adf 100644
--- a/domoticz.install
+++ b/domoticz.install
@@ -1,5 +1,5 @@
post_install() {
- printf "post_instal...\n"
+ printf "post_install...\n"
gpasswd -a http uucp
chown -R http:http "${pkgdir}/opt/domoticz"
}
diff --git a/domoticz.service b/domoticz.service
index ea71ce28eaea..691dee388817 100644
--- a/domoticz.service
+++ b/domoticz.service
@@ -6,9 +6,9 @@ After=network.target
User=http
Group=http
PermissionsStartOnly=true
-ExecStartPre=/usr/bin/install -d -m 0700 -o http -g http /var/run/domoticz
-ExecStart=/opt/domoticz/domoticz -www 8080 -pidfile /var/run/domoticz/domoticz.pid
-PIDFile=/var/run/domoticz/domoticz.pid
+ExecStartPre=/usr/bin/install -d -m 0700 -o http -g http /run/domoticz
+ExecStart=/opt/domoticz/domoticz -www 8080 -pidfile /run/domoticz/domoticz.pid
+PIDFile=/run/domoticz/domoticz.pid
WorkingDirectory=/opt/domoticz
RestartSec=5
Restart=on-failure