summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD41
-rw-r--r--domoticz-beta.install6
-rw-r--r--domoticz.service13
5 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31e1be3e931e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = domoticz
+ pkgdesc = Web based home automation
+ pkgver = 3.5877
+ pkgrel = 1
+ url = http://www.domoticz.com
+ install = domoticz-beta.install
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL
+ depends = openzwave-git
+ depends = libusb-compat
+ depends = curl
+ depends = sqlite
+ depends = boost-libs
+ conflicts = domoticz-svn
+ conflicts = domoticz-git
+ conflicts = domoticz-beta
+ source = https://releases.domoticz.com/releases/release/domoticz_linux_x86_64.tgz
+ source = https://releases.domoticz.com/releases/release/history_linux_x86_64.txt
+ source = domoticz.service
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 8627b3a82db83a0d94c830c007c09ffd38366505fced9c724a7c29414837f3ad
+
+pkgname = domoticz
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..58c0555641dc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.xz
+*.tgz
+*.txt
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9dc4ea4150c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: IanDury
+
+pkgname=domoticz
+pkgver=3.5877
+pkgrel=1
+pkgdesc="Web based home automation"
+arch=('x86_64' 'arm' 'armv6h' 'armv7h')
+url="http://www.domoticz.com"
+license=('GPL')
+depends=('openzwave-git' 'libusb-compat' 'curl' 'sqlite' 'boost-libs')
+conflicts=('domoticz-svn' 'domoticz-git' 'domoticz-beta')
+install='domoticz-beta.install'
+case $CARCH in
+ armv8*)
+ _target_arch=aarch64
+ ;;
+ arm*)
+ _target_arch=armv7l
+ ;;
+ *)
+ _target_arch=$CARCH
+ ;;
+esac
+
+source=("https://releases.domoticz.com/releases/release/domoticz_linux_${_target_arch}.tgz"
+ "https://releases.domoticz.com/releases/release/history_linux_${_target_arch}.txt"
+ 'domoticz.service')
+sha256sums=('SKIP' 'SKIP'
+ '8627b3a82db83a0d94c830c007c09ffd38366505fced9c724a7c29414837f3ad')
+
+pkgver() {
+ echo "$(grep ^Version history_linux_${_target_arch}.txt | head -1 | cut -d' ' -f2)"
+}
+
+package() {
+ mkdir -p "${pkgdir}/opt/domoticz/"
+ cp -R Config domoticz History.txt License.txt scripts server_cert.pem www domoticz.sh history_linux_${_target_arch}.txt "${pkgdir}/opt/domoticz/"
+ mkdir -p "${pkgdir}/usr/lib/systemd/system"
+ cp ../domoticz.service "${pkgdir}/usr/lib/systemd/system/"
+ chown -R http:http "${pkgdir}/opt/domoticz"
+}
diff --git a/domoticz-beta.install b/domoticz-beta.install
new file mode 100644
index 000000000000..3afe115ee535
--- /dev/null
+++ b/domoticz-beta.install
@@ -0,0 +1,6 @@
+post_install() {
+ printf "post_instal...\n"
+ gpasswd -a http uucp
+ chown -R http:http "${pkgdir}/opt/domoticz"
+}
+
diff --git a/domoticz.service b/domoticz.service
new file mode 100644
index 000000000000..38447b18da5b
--- /dev/null
+++ b/domoticz.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Domoticz Daemon
+After=network.target
+
+[Service]
+User=http
+ExecStart=/opt/domoticz/domoticz -www 8080 -daemon
+WorkingDirectory=/opt/domoticz
+RestartSec=5
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target