summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD60
-rw-r--r--domoticz.install1
-rw-r--r--domoticz.service7
4 files changed, 50 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9087cc26d1bf..c1c5dbb3d1d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,29 @@
pkgbase = domoticz
pkgdesc = Web based home automation
- pkgver = 3.5877
- pkgrel = 2
+ pkgver = 3.8153
+ pkgrel = 1
url = http://www.domoticz.com
install = domoticz.install
+ arch = i686
arch = x86_64
arch = arm
arch = armv6h
arch = armv7h
license = GPL
- depends = openzwave-git
+ makedepends = git
+ makedepends = cmake
+ makedepends = boost
+ depends = openzwave
depends = libusb-compat
depends = curl
depends = sqlite
depends = boost-libs
- depends = libcurl-compat
- conflicts = domoticz-svn
- conflicts = domoticz-git
- conflicts = domoticz-beta
- source = https://releases.domoticz.com/releases/release/domoticz_linux_x86_64.tgz
- source = https://releases.domoticz.com/releases/release/history_linux_x86_64.txt
+ depends = lua52
+ depends = mosquitto
+ source = https://github.com/domoticz/domoticz/archive/3.8153.tar.gz
source = domoticz.service
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = bf9e8cd4e1215ac3847bee60e7078777dbcd14787b33ecc443de451a1b0a1728
+ sha256sums = 5ea8f37f2ef900e9bd17b1b5375e75bfdec4f09001e3e2e0b647a260989d014c
+ sha256sums = 52ea28893fc70a278a728f975c249ace48e48f595c9da01895bde115e8e6b255
pkgname = domoticz
diff --git a/PKGBUILD b/PKGBUILD
index c0badaca0329..6ad1364f6580 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,47 @@
-# Maintainer: IanDury
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
pkgname=domoticz
-pkgver=3.5877
-pkgrel=2
+pkgver=3.8153
+pkgrel=1
pkgdesc="Web based home automation"
-arch=('x86_64' 'arm' 'armv6h' 'armv7h')
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url="http://www.domoticz.com"
license=('GPL')
-depends=('openzwave-git' 'libusb-compat' 'curl' 'sqlite' 'boost-libs' 'libcurl-compat')
-conflicts=('domoticz-svn' 'domoticz-git' 'domoticz-beta')
+depends=('openzwave' 'libusb-compat' 'curl' 'sqlite' 'boost-libs' 'lua52' 'mosquitto')
+makedepends=('git' 'cmake' 'boost')
install='domoticz.install'
-case $CARCH in
- armv8*)
- _target_arch=aarch64
- ;;
- arm*)
- _target_arch=armv7l
- ;;
- *)
- _target_arch=$CARCH
- ;;
-esac
-
-source=("https://releases.domoticz.com/releases/release/domoticz_linux_${_target_arch}.tgz"
- "https://releases.domoticz.com/releases/release/history_linux_${_target_arch}.txt"
+source=("https://github.com/domoticz/domoticz/archive/${pkgver}.tar.gz"
'domoticz.service')
-sha256sums=('SKIP' 'SKIP'
- 'bf9e8cd4e1215ac3847bee60e7078777dbcd14787b33ecc443de451a1b0a1728')
+sha256sums=('5ea8f37f2ef900e9bd17b1b5375e75bfdec4f09001e3e2e0b647a260989d014c'
+ '52ea28893fc70a278a728f975c249ace48e48f595c9da01895bde115e8e6b255')
+
+prepare() {
+ mkdir -p ${srcdir}/${pkgname}-${pkgver}/build
+}
-pkgver() {
- echo "$(grep ^Version history_linux_${_target_arch}.txt | head -1 | cut -d' ' -f2)"
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}/build
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/domoticz \
+ -DUSE_STATIC_OPENZWAVE=NO \
+ -DUSE_BUILTIN_LUA=NO \
+ -DUSE_BUILTIN_MQTT=NO \
+ -DUSE_BUILTIN_SQLITE=NO \
+ -DUSE_BUILTIN_ZLIB=NO \
+ -DUSE_STATIC_BOOST=NO \
+ -DUSE_STATIC_LIBSTDCXX=NO \
+ -DUSE_STATIC_OPENZWAVE=NO \
+ ..
}
package() {
- mkdir -p "${pkgdir}/opt/domoticz/"
- cp -R Config domoticz History.txt License.txt scripts server_cert.pem www domoticz.sh history_linux_${_target_arch}.txt "${pkgdir}/opt/domoticz/"
+ cd ${srcdir}/${pkgname}-${pkgver}/build
+
+ make DESTDIR=${pkgdir} install
+ chmod o+r "${pkgdir}/opt/domoticz/updatedomo"
mkdir -p "${pkgdir}/usr/lib/systemd/system"
- cp ../domoticz.service "${pkgdir}/usr/lib/systemd/system/"
+ cp ${srcdir}/domoticz.service "${pkgdir}/usr/lib/systemd/system/"
chown -R http:http "${pkgdir}/opt/domoticz"
}
+
+# vim:set ts=2 sw=2 et:
diff --git a/domoticz.install b/domoticz.install
index 3afe115ee535..2e16f59b7750 100644
--- a/domoticz.install
+++ b/domoticz.install
@@ -3,4 +3,3 @@ post_install() {
gpasswd -a http uucp
chown -R http:http "${pkgdir}/opt/domoticz"
}
-
diff --git a/domoticz.service b/domoticz.service
index 60e3b4593cf2..ea71ce28eaea 100644
--- a/domoticz.service
+++ b/domoticz.service
@@ -3,9 +3,12 @@ Description=Domoticz Daemon
After=network.target
[Service]
-Environment=LD_PRELOAD=/usr/lib/libcurl.so.3
User=http
-ExecStart=/opt/domoticz/domoticz -www 8080 -daemon
+Group=http
+PermissionsStartOnly=true
+ExecStartPre=/usr/bin/install -d -m 0700 -o http -g http /var/run/domoticz
+ExecStart=/opt/domoticz/domoticz -www 8080 -pidfile /var/run/domoticz/domoticz.pid
+PIDFile=/var/run/domoticz/domoticz.pid
WorkingDirectory=/opt/domoticz
RestartSec=5
Restart=on-failure