summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--fix-boost1.66-api.diff37
3 files changed, 48 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b42e3f3dff9f..175c95b33380 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Jan 7 17:24:02 UTC 2018
+# Sun Jan 7 18:35:10 UTC 2018
pkgbase = domoticz-git
pkgdesc = Web based home automation
pkgver = r8799
- pkgrel = 1
+ pkgrel = 2
url = http://www.domoticz.com
install = domoticz-git.install
arch = i686
@@ -26,8 +26,10 @@ pkgbase = domoticz-git
conflicts = domoticz-svn
source = git+https://github.com/domoticz/domoticz.git
source = domoticz.service
+ source = fix-boost1.66-api.diff
sha256sums = SKIP
sha256sums = f45f382e5ae0d54f1b1f147b89f5ac5f62719c83a8eb280e20121f8dfc7b2697
+ sha256sums = da747e0ade1d374509e42faaf5167da779830b9a98e31a1c903734dfa0028b39
pkgname = domoticz-git
diff --git a/PKGBUILD b/PKGBUILD
index 1b1f0c0fabd0..247c07b12aeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=domoticz-git
_gitname="domoticz"
pkgver=r8799
-pkgrel=1
+pkgrel=2
pkgdesc="Web based home automation"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url="http://www.domoticz.com"
@@ -14,9 +14,11 @@ makedepends=('git' 'cmake' 'boost')
conflicts=('domoticz-svn')
install='domoticz-git.install'
source=('git+https://github.com/domoticz/domoticz.git'
- 'domoticz.service')
+ 'domoticz.service'
+ 'fix-boost1.66-api.diff')
sha256sums=('SKIP'
- 'f45f382e5ae0d54f1b1f147b89f5ac5f62719c83a8eb280e20121f8dfc7b2697')
+ 'f45f382e5ae0d54f1b1f147b89f5ac5f62719c83a8eb280e20121f8dfc7b2697'
+ 'da747e0ade1d374509e42faaf5167da779830b9a98e31a1c903734dfa0028b39')
pkgver() {
cd "$_gitname"
@@ -27,6 +29,8 @@ pkgver() {
build() {
cd "$_gitname"
+ patch -p1 < "$srcdir/fix-boost1.66-api.diff"
+
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DUSE_BUILTIN_LUA=NO \
diff --git a/fix-boost1.66-api.diff b/fix-boost1.66-api.diff
new file mode 100644
index 000000000000..0496f251584b
--- /dev/null
+++ b/fix-boost1.66-api.diff
@@ -0,0 +1,37 @@
+diff --git a/webserver/proxyclient.cpp b/webserver/proxyclient.cpp
+index 6bd6b8771..646cfdeee 100644
+--- a/webserver/proxyclient.cpp
++++ b/webserver/proxyclient.cpp
+@@ -770,8 +770,8 @@ namespace http {
+ void CProxyManager::StartThread()
+ {
+ try {
+- //boost::asio::ssl::context ctx(io_service, boost::asio::ssl::context::tlsv12_client);
+- boost::asio::ssl::context ctx(io_service, boost::asio::ssl::context::sslv23);
++ //boost::asio::ssl::context ctx(boost::asio::ssl::context::tlsv12_client);
++ boost::asio::ssl::context ctx(boost::asio::ssl::context::sslv23);
+ ctx.set_verify_mode(boost::asio::ssl::verify_none);
+
+ proxyclient.reset(new CProxyClient(io_service, ctx, m_pWebEm));
+diff --git a/webserver/server.cpp b/webserver/server.cpp
+index fe001e811..c0eec2166 100644
+--- a/webserver/server.cpp
++++ b/webserver/server.cpp
+@@ -152,7 +152,7 @@ void server::handle_accept(const boost::system::error_code& e) {
+ ssl_server::ssl_server(const ssl_server_settings & ssl_settings, request_handler & user_request_handler) :
+ server_base(ssl_settings, user_request_handler),
+ settings_(ssl_settings),
+- context_(io_service_, ssl_settings.get_ssl_method())
++ context_(ssl_settings.get_ssl_method())
+ {
+ #ifdef DEBUG_WWW
+ _log.Log(LOG_STATUS, "[web:%s] create ssl_server using ssl_server_settings : %s", ssl_settings.listening_port.c_str(), ssl_settings.to_string().c_str());
+@@ -165,7 +165,7 @@ ssl_server::ssl_server(const ssl_server_settings & ssl_settings, request_handler
+ ssl_server::ssl_server(const server_settings & settings, request_handler & user_request_handler) :
+ server_base(settings, user_request_handler),
+ settings_(dynamic_cast<ssl_server_settings const &>(settings)),
+- context_(io_service_, dynamic_cast<ssl_server_settings const &>(settings).get_ssl_method()) {
++ context_(dynamic_cast<ssl_server_settings const &>(settings).get_ssl_method()) {
+ #ifdef DEBUG_WWW
+ _log.Log(LOG_STATUS, "[web:%s] create ssl_server using server_settings : %s", settings.listening_port.c_str(), settings.to_string().c_str());
+ #endif