summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD38
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e757f84b441a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = dooble-bin
+ pkgdesc = Dooble is the scientific browser
+ pkgver = 2021.08.05
+ pkgrel = 1
+ url = https://textbrowser.github.io/dooble/
+ arch = x86_64
+ license = BSD
+ depends = alsa-lib
+ depends = fontconfig
+ depends = libgl
+ depends = libxcomposite
+ depends = libxkbcommon
+ depends = libxrandr
+ depends = nss
+ conflicts = dooble
+ noextract = Dooble-2021.08.05_amd64.deb
+ options = !strip
+ source = https://github.com/textbrowser/dooble/releases/download/2021.08.05/Dooble-2021.08.05_amd64.deb
+ source = LICENSE-2021.08.05::https://github.com/textbrowser/dooble/raw/2021.08.05/LICENSE
+ sha256sums = afa11baecc2504ae63f9c8cd62c8a6bfbb994ff03db6e2cf0d9f2562b7163641
+ sha256sums = c60bf2d6a8bfdf7c7418bba91c6767cbb4b48dccae36dd5d9ffdb48f756815dd
+
+pkgname = dooble-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..11762378c066
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*
+!.gitignore
+!PKGBUILD
+!*.patch
+!*.install
+!*.sysusers
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..926badc59178
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
+
+_pkgname=dooble
+_repourl="https://github.com/textbrowser/dooble"
+
+pkgname=dooble-bin
+pkgver=2021.08.05
+pkgrel=1
+pkgdesc="Dooble is the scientific browser"
+arch=('x86_64')
+url="https://textbrowser.github.io/dooble/"
+license=('BSD')
+conflicts=('dooble')
+options=('!strip')
+depends=('alsa-lib' 'fontconfig' 'libgl' 'libxcomposite' 'libxkbcommon' 'libxrandr' 'nss')
+source=(
+ "https://github.com/textbrowser/dooble/releases/download/${pkgver}/Dooble-${pkgver}_amd64.deb"
+ "LICENSE-${pkgver}::${_repourl}/raw/${pkgver}/LICENSE"
+)
+noextract=("Dooble-${pkgver}_amd64.deb")
+sha256sums=(
+ 'afa11baecc2504ae63f9c8cd62c8a6bfbb994ff03db6e2cf0d9f2562b7163641'
+ 'c60bf2d6a8bfdf7c7418bba91c6767cbb4b48dccae36dd5d9ffdb48f756815dd'
+)
+
+package() {
+ bsdtar -O -xf "Dooble-${pkgver}_amd64.deb" data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
+
+ # Permission fix
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+
+ # Documentation
+ install -d "${pkgdir}/usr/share/doc"
+ ln -s "/opt/dooble/Documentation" "${pkgdir}/usr/share/doc/${_pkgname}"
+
+ # License
+ install -D -m644 "LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}