summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD6
-rw-r--r--default-to-fast-bios.patch26
3 files changed, 22 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 068070b5070a..a882d04c7122 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dosbox-x-fast-bios-git
pkgdesc = x86 emulator with builtin DOS, with patches with more features, with fastbios on by default
- pkgver = 12155.c5496a1a0
+ pkgver = 18372.cdcfb5549
pkgrel = 1
url = http://dosbox.sourceforge.net
arch = i686
@@ -15,14 +15,13 @@ pkgbase = dosbox-x-fast-bios-git
depends = mesa
depends = ffmpeg
conflicts = dosbox-x-git
- source = dosbox-x::git://github.com/joncampbell123/dosbox-x.git
+ source = dosbox-x::git+https://github.com/joncampbell123/dosbox-x.git
source = default-to-fast-bios.patch
source = dosbox-x.png
source = dosbox-x.desktop
- md5sums = SKIP
- md5sums = 72303aba7f3d1ad98f81910124350f44
- md5sums = 3dcfe45c5ed0433316eaea51e3620b36
- md5sums = 615228a51b52d4788c73940602f1dc97
+ sha256sums = SKIP
+ sha256sums = bc1665ef70ad255dcc560f40aab7808610985481f104f0e170ad28609d9c5b89
+ sha256sums = caa164f3d17d414733882d29098cb9cd63faddbdd5580a0c30f1173a63c42475
+ sha256sums = 32f290580ec02dedd09908d8a4de10f57b94998f2c1eb597b649208cd87b2d33
pkgname = dosbox-x-fast-bios-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 839bb6cc8e9f..d0c04318ce74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Mantainer: Cork
pkgname=dosbox-x-fast-bios-git
-pkgver=12155.c5496a1a0
+pkgver=18372.cdcfb5549
pkgrel=1
pkgdesc="x86 emulator with builtin DOS, with patches with more features, with fastbios on by default"
arch=(i686 x86_64)
@@ -11,7 +11,7 @@ depends=(fluidsynth libxkbfile libpng libxrandr mesa ffmpeg)
conflicts=(dosbox-x-git)
makedepends=(git glu)
optdepends=()
-source=(dosbox-x::git://github.com/joncampbell123/dosbox-x.git
+source=(dosbox-x::git+https://github.com/joncampbell123/dosbox-x.git
default-to-fast-bios.patch
dosbox-x.png
dosbox-x.desktop)
@@ -38,6 +38,6 @@ package() {
}
sha256sums=('SKIP'
- '4597633a842e60243bd190dbd36f613951aceeb1bd75f3af6229f60ade58f926'
+ 'bc1665ef70ad255dcc560f40aab7808610985481f104f0e170ad28609d9c5b89'
'caa164f3d17d414733882d29098cb9cd63faddbdd5580a0c30f1173a63c42475'
'32f290580ec02dedd09908d8a4de10f57b94998f2c1eb597b649208cd87b2d33')
diff --git a/default-to-fast-bios.patch b/default-to-fast-bios.patch
index c51748ef902b..d62e10f82cb4 100644
--- a/default-to-fast-bios.patch
+++ b/default-to-fast-bios.patch
@@ -1,30 +1,30 @@
diff --git a/include/control.h b/include/control.h
-index f99ababd8..fcd5e54d4 100644
+index d9dcbf173..401365725 100644
--- a/include/control.h
+++ b/include/control.h
@@ -87,7 +87,7 @@ public:
- opt_printconf = false;
- opt_noautoexec = false;
- opt_securemode = false;
-- opt_fastlaunch = false;
-+ opt_fastlaunch = true;
- opt_fullscreen = false;
- opt_showcycles = false;
- opt_earlydebug = false;
+ bool opt_noautoexec = false;
+ bool opt_securemode = false;
+ bool opt_fullscreen = false;
+- bool opt_fastlaunch = false;
++ bool opt_fastlaunch = true;
+ bool opt_showcycles = false;
+ bool opt_earlydebug = false;
+ bool opt_logfileio = false;
diff --git a/src/gui/sdlmain.cpp b/src/gui/sdlmain.cpp
-index a54b9a3e2..b25f865ee 100644
+index 77a0e2917..859b4cea4 100644
--- a/src/gui/sdlmain.cpp
+++ b/src/gui/sdlmain.cpp
-@@ -6953,7 +6953,7 @@ bool DOSBOX_parse_argv() {
+@@ -6892,7 +6892,7 @@ bool DOSBOX_parse_argv() {
fprintf(stderr," -set <section property=value> Set the config option (overriding the config file).\n");
fprintf(stderr," Make sure to surround the string in quotes to cover spaces.\n");
fprintf(stderr," -time-limit <n> Kill the emulator after 'n' seconds\n");
- fprintf(stderr," -fastlaunch Fast launch mode (skip the BIOS logo and welcome banner)\n");
-+ fprintf(stderr," -launchlogo Show launch logo (show the launch logo and welcome banner)\n");
++ fprintf(stderr," -launchlogo Show launch logo (show the BIOS logo and welcome banner)\n");
#if C_DEBUG
fprintf(stderr," -helpdebug Show debug-related options\n");
#endif
-@@ -7074,8 +7074,8 @@ bool DOSBOX_parse_argv() {
+@@ -7060,8 +7060,8 @@ bool DOSBOX_parse_argv() {
else if (optname == "fastbioslogo") {
control->opt_fastbioslogo = true;
}