summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD45
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f32d99b054d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dosfstools-git
+ pkgdesc = DOS filesystem utilities
+ pkgver = 4.1.r86.gfc55b63
+ pkgrel = 1
+ url = https://github.com/dosfstools/dosfstools
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = glibc
+ provides = dosfstools
+ conflicts = dosfstools
+ source = git+https://github.com/dosfstools/dosfstools.git
+ sha256sums = SKIP
+
+pkgname = dosfstools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07e8c16eaeb7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=dosfstools-git
+pkgver=4.1.r86.gfc55b63
+pkgrel=1
+pkgdesc="DOS filesystem utilities"
+arch=('i686' 'x86_64')
+url="https://github.com/dosfstools/dosfstools"
+license=('GPL3')
+depends=('glibc')
+makedepends=('git')
+provides=('dosfstools')
+conflicts=('dosfstools')
+source=("git+https://github.com/dosfstools/dosfstools.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "dosfstools"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "dosfstools"
+
+ autoreconf -fi
+ ./configure \
+ --prefix="/usr" \
+ --sbindir="/usr/bin" \
+ --enable-compat-symlinks
+ make
+}
+
+check() {
+ cd "dosfstools"
+
+ #make check
+}
+
+package() {
+ cd "dosfstools"
+
+ make DESTDIR="$pkgdir" install
+}