summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO57
-rw-r--r--PKGBUILD105
2 files changed, 5 insertions, 157 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37959fa07d50..d90b74ba41e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dotnet-core-preview-bin
pkgver = 8.0.0.sdk100+preview.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.microsoft.com/net/core
arch = armv7h
arch = aarch64
@@ -22,63 +22,10 @@ pkgbase = dotnet-core-preview-bin
source_x86_64 = https://download.visualstudio.microsoft.com/download/pr/e2578737-231b-493c-a6ee-f181496fe679/18038808d2621094ebe172ca011a7c22/dotnet-sdk-8.0.100-preview.1.23115.2-linux-x64.tar.gz
sha512sums_x86_64 = 23a14c92e402161ed8d42ec9cb25a97868a1b72348195d28cffa00a12815f019308b56485e4375c0d0a33d9a683d83cc1e1a2a517eea44af8fb353171b6c3f64
-pkgname = dotnet-host-preview-bin
+pkgname = dotnet-core-host-preview-bin
pkgdesc = A generic driver for the .NET Core Command Line Interface (preview, binary)
depends = glibc
provides = dotnet-host
provides = dotnet-host=8.0.0
conflicts = dotnet-host
replaces = dotnet-host-preview
-
-pkgname = aspnet-runtime-preview-bin
- pkgdesc = The ASP.NET Core runtime (preview, binary)
- depends = dotnet-runtime-preview-bin
- provides = aspnet-runtime=8.0.0
- provides = aspnet-runtime-8.0
- conflicts = aspnet-runtime=8.0.0
- replaces = aspnet-runtime-preview
-
-pkgname = dotnet-runtime-preview-bin
- pkgdesc = The .NET Core runtime (preview, binary)
- depends = dotnet-host>=8.0.0
- depends = glibc
- depends = icu
- depends = krb5
- depends = libcurl.so
- depends = libunwind
- depends = openssl
- depends = zlib
- optdepends = lttng-ust: CoreCLR tracing
- optdepends = msquic>=2.1.0: HTTP/3 support with System.Net.Quic
- provides = dotnet-runtime=8.0.0
- provides = dotnet-runtime-8.0
- conflicts = dotnet-runtime=8.0.0
- replaces = dotnet-runtime-preview
-
-pkgname = dotnet-sdk-preview-bin
- pkgdesc = The .NET Core SDK (preview, binary)
- depends = dotnet-runtime-preview-bin
- depends = dotnet-targeting-pack-preview-bin
- depends = glibc
- depends = netstandard-targeting-pack-2.1
- optdepends = aspnet-targeting-pack-preview-bin: Build ASP.NET Core applications
- provides = dotnet-sdk=8.0.100
- provides = dotnet-sdk-8.0
- conflicts = dotnet-sdk=8.0.100
- replaces = dotnet-sdk-preview
-
-pkgname = dotnet-targeting-pack-preview-bin
- pkgdesc = The .NET Core targeting pack (preview, binary)
- depends = netstandard-targeting-pack-2.1
- provides = dotnet-targeting-pack=8.0.0
- provides = dotnet-targeting-pack-8.0
- conflicts = dotnet-targeting-pack=8.0.0
- replaces = dotnet-targeting-pack-preview
-
-pkgname = aspnet-targeting-pack-preview-bin
- pkgdesc = The ASP.NET Core targeting pack (preview, binary)
- depends = dotnet-targeting-pack-preview-bin
- provides = aspnet-targeting-pack=8.0.0
- provides = aspnet-targeting-pack-8.0
- conflicts = aspnet-targeting-pack=8.0.0
- replaces = aspnet-targeting-pack-preview
diff --git a/PKGBUILD b/PKGBUILD
index 5dd369424bd9..a955525de5d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,20 +5,14 @@
pkgbase=dotnet-core-preview-bin
pkgname=(
- dotnet-host-preview-bin
- aspnet-runtime-preview-bin
- dotnet-runtime-preview-bin
- dotnet-sdk-preview-bin
- # netstandard-targeting-pack-preview-bin
- dotnet-targeting-pack-preview-bin
- aspnet-targeting-pack-preview-bin
+ dotnet-core-host-preview-bin
)
pkgver=8.0.0.sdk100+preview.1
_hostver=8.0.0-preview.1.23110.8
_dotnetruntimever=8.0.0-preview.1.23110.8
_aspnetruntimever=8.0.0-preview.1.23112.2
_sdkver=8.0.100-preview.1.23115.2
-pkgrel=1
+pkgrel=2
arch=(armv7h aarch64 x86_64)
url=https://www.microsoft.com/net/core
license=(MIT)
@@ -38,7 +32,7 @@ sha512sums_armv7h=('b1d9f2bad2c00412c2efa1821e972df317fa6bb5e2eb51e34c871d10d20b
sha512sums_aarch64=('98518887927605051312554499e197c14b32e8100fe8d8015a4556fdca3a347a3d2215d14069d33b27d978489f3e958c11baf18ba33e1b98580d2eb64cc1097b')
sha512sums_x86_64=('23a14c92e402161ed8d42ec9cb25a97868a1b72348195d28cffa00a12815f019308b56485e4375c0d0a33d9a683d83cc1e1a2a517eea44af8fb353171b6c3f64')
-package_dotnet-host-preview-bin() {
+package_dotnet-core-host-preview-bin() {
pkgdesc='A generic driver for the .NET Core Command Line Interface (preview, binary)'
depends=(glibc)
provides=(dotnet-host dotnet-host=${_hostver%-*})
@@ -55,96 +49,3 @@ package_dotnet-host-preview-bin() {
install -Dm 644 "${srcdir}"/register-completions.fish "${pkgdir}"/usr/share/fish/vendor_completions.d/dotnet.fish
install -Dm 644 "${srcdir}"/register-completions.zsh "${pkgdir}"/usr/share/zsh/site-functions/_dotnet
}
-
-package_dotnet-runtime-preview-bin() {
- pkgdesc='The .NET Core runtime (preview, binary)'
- depends=(
- "dotnet-host>=${_hostver%-*}"
- glibc
- icu
- krb5
- libcurl.so
- libunwind
- openssl
- zlib
- )
-
- optdepends=('lttng-ust: CoreCLR tracing'
- 'msquic>=2.1.0: HTTP/3 support with System.Net.Quic')
- provides=(dotnet-runtime=${_dotnetruntimever%-*} dotnet-runtime-8.0)
- conflicts=(dotnet-runtime=${_dotnetruntimever%-*})
- replaces=(dotnet-runtime-preview)
-
- install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
- cp -dr --no-preserve='ownership' shared/Microsoft.NETCore.App "${pkgdir}"/usr/share/dotnet/shared/
- ln -s dotnet-host-preview-bin "${pkgdir}"/usr/share/licenses/dotnet-runtime-preview-bin
-}
-
-package_aspnet-runtime-preview-bin() {
- pkgdesc='The ASP.NET Core runtime (preview, binary)'
- depends=(dotnet-runtime-preview-bin)
- provides=(aspnet-runtime=${_aspnetruntimever%-*} aspnet-runtime-8.0)
- conflicts=(aspnet-runtime=${_aspnetruntimever%-*})
- replaces=(aspnet-runtime-preview)
-
- install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
- cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/usr/share/dotnet/shared/
- ln -s dotnet-host-preview-bin "${pkgdir}"/usr/share/licenses/aspnet-runtime-preview-bin
-}
-
-package_dotnet-sdk-preview-bin() {
- pkgdesc='The .NET Core SDK (preview, binary)'
- depends=(
- dotnet-runtime-preview-bin
- dotnet-targeting-pack-preview-bin
- glibc
- netstandard-targeting-pack-2.1
- )
- optdepends=('aspnet-targeting-pack-preview-bin: Build ASP.NET Core applications')
- provides=(dotnet-sdk=${_sdkver%-*} dotnet-sdk-8.0)
- conflicts=(dotnet-sdk=${_sdkver%-*})
- replaces=(dotnet-sdk-preview)
-
- install -dm 755 "${pkgdir}"/usr/share/{dotnet,licenses}
- cp -dr --no-preserve='ownership' sdk sdk-manifests templates "${pkgdir}"/usr/share/dotnet/
- ln -s dotnet-host-preview-bin "${pkgdir}"/usr/share/licenses/dotnet-sdk-preview-bin
-}
-
-# package_netstandard-targeting-pack-preview-bin() {
-# pkgdesc='The .NET Standard targeting pack (preview, binary)'
-# provides=(netstandard-targeting-pack-2.1)
-# conflicts=(netstandard-targeting-pack-2.1)
-# replaces=(netstandard-targeting-pack-preview)
-
-# install -dm 755 "${pkgdir}"/usr/share/{dotnet,dotnet/packs,licenses}
-# cp -dr --no-preserve='ownership' packs/NETStandard.Library.Ref "${pkgdir}"/usr/share/dotnet/packs/
-# ln -s dotnet-host-preview-bin "${pkgdir}"/usr/share/licenses/netstandard-targeting-pack-preview-bin
-# }
-
-package_dotnet-targeting-pack-preview-bin() {
- pkgdesc='The .NET Core targeting pack (preview, binary)'
- depends=(netstandard-targeting-pack-2.1)
- provides=(dotnet-targeting-pack=${_dotnetruntimever%-*} dotnet-targeting-pack-8.0)
- conflicts=(dotnet-targeting-pack=${_dotnetruntimever%-*})
- replaces=(dotnet-targeting-pack-preview)
-
- if [ $CARCH = 'x86_64' ]; then msarch=x64;
- elif [ $CARCH = 'aarch64' ]; then msarch=arm64;
- elif [ $CARCH = 'armv7h' ]; then msarch=arm; fi
-
- install -dm 755 "${pkgdir}"/usr/share/{dotnet,dotnet/packs,licenses}
- cp -dr --no-preserve='ownership' packs/Microsoft.NETCore.App.{Host.linux-${msarch},Ref} "${pkgdir}"/usr/share/dotnet/packs/
- ln -s dotnet-host-preview-bin "${pkgdir}"/usr/share/licenses/dotnet-targeting-pack-preview-bin
-}
-
-package_aspnet-targeting-pack-preview-bin() {
- pkgdesc='The ASP.NET Core targeting pack (preview, binary)'
- depends=(dotnet-targeting-pack-preview-bin)
- provides=(aspnet-targeting-pack=${_aspnetruntimever%-*} aspnet-targeting-pack-8.0)
- conflicts=(aspnet-targeting-pack=${_aspnetruntimever%-*})
- replaces=(aspnet-targeting-pack-preview)
-
- install -dm 755 "${pkgdir}"/usr/share/{dotnet,dotnet/packs,licenses}
- cp -dr --no-preserve='ownership' packs/Microsoft.AspNetCore.App.Ref "${pkgdir}"/usr/share/dotnet/packs/
- ln -s dotnet-host-preview-bin "${pkgdir}"/usr/share/licenses/aspnet-targeting-pack-preview-bin
-}