summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO30
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD42
-rw-r--r--dowse.install22
-rwxr-xr-xdowse.service10
-rwxr-xr-xdowse.sh4
6 files changed, 138 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..af4ad6896526
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,30 @@
+pkgbase = dowse-git
+ pkgdesc = Minimalistic tool to configure the routing of a local area network
+ pkgver = 81.e365694
+ pkgrel = 1
+ url = https://github.com/dyne/dowse
+ install = dowse.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = zsh
+ depends = privoxy
+ depends = squid
+ depends = dnsmasq
+ depends = tor
+ depends = daemontools
+ depends = iptables
+ depends = ebtables
+ provides = dowse
+ conflicts = dowse
+ backup = usr/share/dowse/conf/network
+ backup = usr/share/dowse/conf/settings
+ source = git://github.com/dyne/dowse.git
+ source = dowse.sh
+ source = dowse.service
+ md5sums = SKIP
+ md5sums = 4d296e0099e15aa82fdf42fbe111dc5d
+ md5sums = 112e9e1e5b0bee78abdd09dba2e7606d
+
+pkgname = dowse-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af4ad6896526
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = dowse-git
+ pkgdesc = Minimalistic tool to configure the routing of a local area network
+ pkgver = 81.e365694
+ pkgrel = 1
+ url = https://github.com/dyne/dowse
+ install = dowse.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = zsh
+ depends = privoxy
+ depends = squid
+ depends = dnsmasq
+ depends = tor
+ depends = daemontools
+ depends = iptables
+ depends = ebtables
+ provides = dowse
+ conflicts = dowse
+ backup = usr/share/dowse/conf/network
+ backup = usr/share/dowse/conf/settings
+ source = git://github.com/dyne/dowse.git
+ source = dowse.sh
+ source = dowse.service
+ md5sums = SKIP
+ md5sums = 4d296e0099e15aa82fdf42fbe111dc5d
+ md5sums = 112e9e1e5b0bee78abdd09dba2e7606d
+
+pkgname = dowse-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbf9a19daf46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=dowse-git
+pkgver=81.e365694
+pkgrel=1
+pkgdesc='Minimalistic tool to configure the routing of a local area network'
+arch=('any')
+url='https://github.com/dyne/dowse'
+license=('GPL')
+depends=('zsh' 'privoxy' 'squid' 'dnsmasq' 'tor' 'daemontools' 'iptables' 'ebtables')
+makedepends=('git')
+conflicts=('dowse')
+provides=('dowse')
+backup=('usr/share/dowse/conf/network' 'usr/share/dowse/conf/settings')
+install=dowse.install
+source=('git://github.com/dyne/dowse.git'
+ 'dowse.sh'
+ 'dowse.service')
+md5sums=('SKIP'
+ '4d296e0099e15aa82fdf42fbe111dc5d'
+ '112e9e1e5b0bee78abdd09dba2e7606d')
+
+pkgver() {
+ cd dowse
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd dowse
+ install -d "${pkgdir}"/usr/share/dowse/conf
+ install -m755 dowse "${pkgdir}"/usr/share/dowse/
+ cp -r {modules,zlibs} "${pkgdir}"/usr/share/dowse/
+ touch "${pkgdir}"/usr/share/dowse/conf/{network,settings}
+
+ install -d "${pkgdir}"/usr/share/doc/dowse
+ cp -r {conf,doc} "${pkgdir}"/usr/share/doc/dowse/
+
+ install -D "${srcdir}"/dowse.sh "${pkgdir}"/usr/bin/dowse
+
+ install -d "${pkgdir}"/usr/lib/systemd/system
+ install "${srcdir}"/dowse.service "${pkgdir}"/usr/lib/systemd/system/
+}
diff --git a/dowse.install b/dowse.install
new file mode 100644
index 000000000000..4f6a64ffdf70
--- /dev/null
+++ b/dowse.install
@@ -0,0 +1,22 @@
+post_install() {
+ getent group dowse >/dev/null 2>&1 || groupadd -r dowse
+ getent passwd dowse >/dev/null 2>&1 || useradd -g dowse -d /usr/share/dowse -s /bin/zsh -r dowse
+ chown -R dowse:dowse /usr/share/dowse
+
+ echo "==> In order to configure dowse you need to adjust both 'network' and 'settings' files"
+ echo " into dowse configuration dir: /usr/share/dowse/conf. See /usr/share/doc/dowse/conf"
+ echo " for exmaples."
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ if getent passwd dowse >/dev/null 2>&1; then
+ userdel dowse
+ fi
+ if getent group dowse >/dev/null 2>&1; then
+ groupdel dowse
+ fi
+}
diff --git a/dowse.service b/dowse.service
new file mode 100755
index 000000000000..2cf3dd64be1f
--- /dev/null
+++ b/dowse.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Dowse
+After=network.target
+
+[Service]
+User=dowse
+ExecStart=/usr/bin/dowse start
+
+[Install]
+WantedBy=multi-user.target
diff --git a/dowse.sh b/dowse.sh
new file mode 100755
index 000000000000..e3315c27d8de
--- /dev/null
+++ b/dowse.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /usr/share/dowse
+zsh ./dowse "$@"