summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--dpp.changelog19
-rw-r--r--dpp.install12
4 files changed, 35 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66bc005e2f4c..0901023aaec8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dpp
pkgdesc = Lightweight and Scalable C++ Discord API Bot Library
- pkgver = 10.0.15
+ pkgver = 10.0.16
pkgrel = 1
url = https://dpp.dev/
install = dpp.install
@@ -14,7 +14,7 @@ pkgbase = dpp
depends = opus
depends = libsodium
depends = nlohmann-json
- source = dpp-10.0.15.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.15.tar.gz
- sha256sums = 5370e7fa3e76ed78b87dc4d9c01cc5a5f1a5789ebf1d3d0e8deff05cb665c539
+ source = dpp-10.0.16.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.16.tar.gz
+ sha256sums = dc99af06d9c2fdeefde534d99c00cbda4c96bac7d02ee68bcbbc2b47848bb28e
pkgname = dpp
diff --git a/PKGBUILD b/PKGBUILD
index 5691e9f3a74a..819f6ab56f1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# See also https://github.com/eremiell-aur/dpp
pkgname=dpp
_pkgname=DPP
-pkgver=10.0.15
+pkgver=10.0.16
pkgrel=1
pkgdesc="Lightweight and Scalable C++ Discord API Bot Library"
arch=('x86_64')
@@ -13,7 +13,7 @@ makedepends=('cmake')
install="${pkgname}.install"
changelog="${pkgname}.changelog"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/brainboxdotcc/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('5370e7fa3e76ed78b87dc4d9c01cc5a5f1a5789ebf1d3d0e8deff05cb665c539')
+sha256sums=('dc99af06d9c2fdeefde534d99c00cbda4c96bac7d02ee68bcbbc2b47848bb28e')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
@@ -22,6 +22,8 @@ prepare() {
sed -i -E "s/libdpp/dpp/" "CMakeLists.txt" "cmake/libdpp-config.cmake"
sed -i -E "s/libdpp-config/dpp-config/" "cmake/CPackSetup.cmake"
mv "cmake/libdpp-config.cmake" "cmake/dpp-config.cmake"
+ sed -i -E "s/^.*dpp\/nlohmann.*$//" "library/CMakeLists.txt"
+ rm -rf "include/dpp/nlohmann"
}
build() {
@@ -35,7 +37,6 @@ build() {
package() {
cd "${srcdir}/${_pkgname}-${pkgver}/build"
make DESTDIR="${pkgdir}/" install
- rm -rf "${pkgdir}/usr/include/dpp/nlohmann"
rm -rf "${pkgdir}/usr/include/dpp-${pkgver%.*}"
install -dm755 "${pkgdir}/usr/lib/cmake/${pkgname}/"
find "${pkgdir}" -iname "*.cmake" -exec mv -t "${pkgdir}/usr/lib/cmake/${pkgname}" '{}' \+
diff --git a/dpp.changelog b/dpp.changelog
index 7df4e1750e26..9a4185479cec 100644
--- a/dpp.changelog
+++ b/dpp.changelog
@@ -1,3 +1,22 @@
+# 10.0.16-1 / 2022-08-18 (2022-09-04)
+
+* bump to new library version
+ * ETF 60% faster
+ * experimental coroutines feature not packaged atm
+ * has issues to build
+ * it could be patched, but the feature itself has issues
+ * see library changelog for full list
+* resolved build warning about link to $srcdir
+ * vendored nlohmann/json now gets removed before the build
+ * this somehow removes a "link" to it in the .so
+ * patched out the pchs while at it
+ * the package wasn't using these anyway
+* originally packaged two weeks back but just releasing now
+ * was trying to fix reprobuilds, we'll get there eventually
+ * wrote the package and changelog at the first date
+ * keeping it for reflection of things
+ * actually releasing at the second date along with future versions
+
# 10.0.15-1 / 2022-08-02
* bump to new library version
diff --git a/dpp.install b/dpp.install
index ec53654af812..60070346b077 100644
--- a/dpp.install
+++ b/dpp.install
@@ -6,7 +6,13 @@ post_install() {
echo -e "\e[1;33mAlso be aware one of the time conversion tests fail on devices not set to UTC.\e[0m"
echo -e "\e[1;33mThis shouldn't affect your server deploys but may play role on your dev machine.\e[0m"
echo ""
- echo -e "\e[32mTo keep things lean and clean, embedded fmt and nlohmann/json\e[0m"
- echo -e "\e[32mhave been replaced by packaged versions.\e[0m"
+ echo -e "\e[32mTo keep things lean and clean, embedded nlohmann/jsonhave been replaced by\e[0m"
+ echo -e "\e[32mpackaged version.\e[0m"
echo -e "\e[32mMind that when looking up online tutorials.\e[0m"
-} \ No newline at end of file
+}
+
+post_upgrade() {
+ echo -e "\e[1;33mEmbedded fmt have been completely dropped off the package.\e[0m"
+ echo -e "\e[1;33mWe already replaced that by systemwide version.\e[0m"
+ echo -e "\e[1;33mJust mind that it's not longer a dependency.\e[0m"
+}