summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--dpp.changelog9
3 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6d5ca72bbea..e9c3e798dbad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dpp
pkgdesc = Lightweight and Scalable C++ Discord API Bot Library
- pkgver = 10.0.23
- pkgrel = 2
+ pkgver = 10.0.24
+ pkgrel = 1
url = https://dpp.dev/
install = dpp.install
changelog = dpp.changelog
@@ -15,7 +15,7 @@ pkgbase = dpp
depends = opus
depends = libsodium
depends = nlohmann-json
- source = dpp-10.0.23.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.23.tar.gz
- sha256sums = 8f9db61c3586a492ada378235300c509e3bc2fc090cef32de0a8241741038df0
+ source = dpp-10.0.24.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.24.tar.gz
+ sha256sums = e5d561b864a7397caeb5616d388ebbd79a8f21077f3b13ac6ccd7e29c746daa9
pkgname = dpp
diff --git a/PKGBUILD b/PKGBUILD
index 23ad7820cf0c..7fd7d4f2216f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# See also https://github.com/eremiell-aur/dpp
pkgname=dpp
_pkgname=DPP
-pkgver=10.0.23
-pkgrel=2
+pkgver=10.0.24
+pkgrel=1
pkgdesc="Lightweight and Scalable C++ Discord API Bot Library"
arch=('x86_64')
url="https://dpp.dev/"
@@ -13,12 +13,12 @@ makedepends=('cmake' 'pkgconf')
install="${pkgname}.install"
changelog="${pkgname}.changelog"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/brainboxdotcc/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('8f9db61c3586a492ada378235300c509e3bc2fc090cef32de0a8241741038df0')
+sha256sums=('e5d561b864a7397caeb5616d388ebbd79a8f21077f3b13ac6ccd7e29c746daa9')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
rm -rf "include/dpp/nlohmann"
- sed -i -E "s/(#pragma once)/\1\n#include <cstdint>/" "include/dpp/sslclient.h"
+ #sed -i -E "s/(#pragma once)/\1\n#include <cstdint>/" "include/dpp/sslclient.h"
}
build() {
diff --git a/dpp.changelog b/dpp.changelog
index 5828c7193cd2..629abd595260 100644
--- a/dpp.changelog
+++ b/dpp.changelog
@@ -1,3 +1,12 @@
+# 10.0.24-1 / 2023-05-25
+
+* bump to new library version
+ * new gateway events supported
+ * support for voice messages
+ * new permissions supported
+ * fix for MIME status in out of Discord HTTP requests
+ * see library changelog for full list
+
# 10.0.23-2 / 2023-05-16
* quick patch for gcc13 compatibility