summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rw-r--r--dpp.changelog9
3 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d36046486139..d9630fd7617e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dpp
pkgdesc = Lightweight and Scalable C++ Discord API Bot Library
- pkgver = 10.0.13
+ pkgver = 10.0.14
pkgrel = 1
url = https://dpp.dev/
install = dpp.install
@@ -12,9 +12,8 @@ pkgbase = dpp
depends = zlib
depends = opus
depends = libsodium
- depends = fmt
depends = nlohmann-json
- source = dpp-10.0.13.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.13.tar.gz
- sha256sums = 35dc9f5dc265d70047df67b13ae45f7345ed3f3b842b114fd89cacb3c83428ed
+ source = dpp-10.0.14.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.14.tar.gz
+ sha256sums = 5eb4cf3b4f4ba200d5f0d57929a1b96cc79e2398004afccc9d9c63aee865ca9d
pkgname = dpp
diff --git a/PKGBUILD b/PKGBUILD
index 926e40053a21..687ff6217bd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
# See also https://github.com/eremiell-aur/dpp
pkgname=dpp
_pkgname=DPP
-pkgver=10.0.13
+pkgver=10.0.14
pkgrel=1
pkgdesc="Lightweight and Scalable C++ Discord API Bot Library"
arch=('x86_64')
url="https://dpp.dev/"
license=('Apache')
-depends=('openssl' 'zlib' 'opus' 'libsodium' 'fmt' 'nlohmann-json')
+depends=('gcc-libs' 'openssl' 'zlib' 'opus' 'libsodium' 'nlohmann-json')
makedepends=('cmake')
install="${pkgname}.install"
changelog="${pkgname}.changelog"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/brainboxdotcc/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('35dc9f5dc265d70047df67b13ae45f7345ed3f3b842b114fd89cacb3c83428ed')
+sha256sums=('5eb4cf3b4f4ba200d5f0d57929a1b96cc79e2398004afccc9d9c63aee865ca9d')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
diff --git a/dpp.changelog b/dpp.changelog
index 5d98208e7344..28499240f1eb 100644
--- a/dpp.changelog
+++ b/dpp.changelog
@@ -1,3 +1,12 @@
+# 10.0.14-1 / 2022-08-02
+
+* bump to new libary version
+ * internal use of fmt got removed
+ * library still vendored for now
+ * clusters an now shutdown and start
+ * see library changelog for full list
+* late release for continuity
+
# 10.0.13-1 / 2022-07-12
* bump to new library version