summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--dpp.changelog15
-rw-r--r--dpp.install18
4 files changed, 28 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e803c4cf1fd9..d27b6ccf170d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dpp
pkgdesc = Lightweight and Scalable C++ Discord API Bot Library
- pkgver = 10.0.22
+ pkgver = 10.0.23
pkgrel = 1
url = https://dpp.dev/
install = dpp.install
@@ -15,7 +15,7 @@ pkgbase = dpp
depends = opus
depends = libsodium
depends = nlohmann-json
- source = dpp-10.0.22.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.22.tar.gz
- sha256sums = f8da36a9e24012fdff55a988e41d2015235b9e564b3151a1e5158fa1c7e05648
+ source = dpp-10.0.23.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.23.tar.gz
+ sha256sums = 8f9db61c3586a492ada378235300c509e3bc2fc090cef32de0a8241741038df0
pkgname = dpp
diff --git a/PKGBUILD b/PKGBUILD
index d4a58f642749..a97973994cbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# See also https://github.com/eremiell-aur/dpp
pkgname=dpp
_pkgname=DPP
-pkgver=10.0.22
+pkgver=10.0.23
pkgrel=1
pkgdesc="Lightweight and Scalable C++ Discord API Bot Library"
arch=('x86_64')
@@ -13,12 +13,10 @@ makedepends=('cmake' 'pkgconf')
install="${pkgname}.install"
changelog="${pkgname}.changelog"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/brainboxdotcc/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('f8da36a9e24012fdff55a988e41d2015235b9e564b3151a1e5158fa1c7e05648')
+sha256sums=('8f9db61c3586a492ada378235300c509e3bc2fc090cef32de0a8241741038df0')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- find . \( -iname "*.h" -o -iname "*.cpp" \) -exec sed -i -E "s/dpp\/(nlohmann)\//\1\//" '{}' \+
- sed -i -E "s/^.*dpp\/nlohmann.*$//" "library/CMakeLists.txt"
rm -rf "include/dpp/nlohmann"
}
@@ -26,7 +24,7 @@ build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
mkdir -p build
cd build
- cmake -DDPP_BUILD_TEST=OFF -DRUN_LDCONFIG=OFF -DDPP_NO_VCPKG=ON -DDPP_CORO=ON -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_MESSAGE=NEVER -Wno-dev ..
+ cmake -DDPP_BUILD_TEST=OFF -DRUN_LDCONFIG=OFF -DDPP_NO_VCPKG=ON -DDPP_CORO=ON -DDPP_USE_EXTERNAL_JSON=ON -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_MESSAGE=NEVER -Wno-dev ..
make
}
diff --git a/dpp.changelog b/dpp.changelog
index cde4417a2965..c7c46cfaaf3e 100644
--- a/dpp.changelog
+++ b/dpp.changelog
@@ -1,3 +1,14 @@
+# 10.0.23-1 / 2023-03-01
+
+* bump to new library version
+ * support for various new small Discord features
+ * various fixes
+ * see library for full changelog
+* upstream cmake now lets us use systemwide nlohmann::json
+ * was able to drop majority of our patches
+ * we still ship symlink
+ * mind that you may now need to add a define to your build
+
# 10.0.22-1 / 2023-01-08
* bump to new library version
@@ -6,8 +17,8 @@
* various fixes
* see library changelog for full list
* changes to upstream cmake changed way we deal with that
- * all cmake speific patches have been dropped
- * find_package should now wor as intended
+ * all cmake specific patches have been dropped
+ * find_package should now work as intended
* pkg-config should continue to work as before
# 10.0.21-1 / 2022-11-02
diff --git a/dpp.install b/dpp.install
index 082116ea8081..f0c6114087d8 100644
--- a/dpp.install
+++ b/dpp.install
@@ -1,10 +1,10 @@
post_install() {
- echo -e "\e[31mBe aware one of the time conversion tests fail on devices not set to UTC.\e[0m"
- echo -e "\e[31mThis shouldn't affect your server deploys but may play role on your dev machine.\e[0m"
+ echo -e "\e[1;31mBe aware one of the time conversion tests fail on devices not set to UTC.\e[0m"
+ echo -e "\e[1;31mThis shouldn't affect your server deploys but may play role on your dev machine.\e[0m"
echo ""
- echo -e "\e[32mTo keep things lean and clean, embedded nlohmann/json have been replaced by\e[0m"
- echo -e "\e[32mpackaged version.\e[0m"
- echo -e "\e[32mSymlink has been provided for convenience, but you may prefer to use it directly.\e[0m"
+ echo -e "\e[1;32mWe build and package with packaged nlohmann/json. This is now properly supported by\e[0m"
+ echo -e "\e[1;32mlibrary build system. You may want to set the new build time flag.\e[0m"
+ echo -e "\e[1;32mSymlink has been provided for convenience, but you may prefer to use it directly.\e[0m"
echo ""
echo -e "\e[1;33mPackage now includes experimental coroutine support.\e[0m"
echo -e "\e[1;33mIt's not considered production ready, but it's available for your experiments.\e[0m"
@@ -12,11 +12,11 @@ post_install() {
}
post_upgrade() {
- echo -e "\e[31mCMake has been finally fixed. If you were using pkg-config up to now, nothing should\e[0m"
- echo -e "\e[31mchange for you, but you an now also just use find_package and it should actually work.\e[0m"
+ echo -e "\e[1;31mCMake has been finally fixed. If you were using pkg-config up to now, nothing should\e[0m"
+ echo -e "\e[1;31mchange for you, but you can now also just use find_package and it should actually work.\e[0m"
echo ""
- echo -e "\e[32mSymlink has been provided for the embedded nlohmann/json library.\e[0m"
- echo -e "\e[32mWe keep using the systemwide version. It's just for easier use of online tutorials.\e[0m"
+ echo -e "\e[1;32mSymlink has been provided for the embedded nlohmann/json library.\e[0m"
+ echo -e "\e[1;32mWe keep using the systemwide version. You may want to set the new build time flag.\e[0m"
echo ""
echo -e "\e[1;33mPackage now includes experimental coroutine support.\e[0m"
echo -e "\e[1;33mIt's not considered production ready, but it's available for your experiments.\e[0m"