summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
-rw-r--r--dpp.changelog11
-rw-r--r--dpp.install2
4 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dbec0ccad60b..97b9db43049c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dpp
pkgdesc = Lightweight and Scalable C++ Discord API Bot Library
- pkgver = 10.0.18
+ pkgver = 10.0.19
pkgrel = 1
url = https://dpp.dev/
install = dpp.install
@@ -14,7 +14,7 @@ pkgbase = dpp
depends = opus
depends = libsodium
depends = nlohmann-json
- source = dpp-10.0.18.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.18.tar.gz
- sha256sums = 0d976673852a5d8e71833d5f6a5b9767ffaf6b6a053d8420fa921adfcb80ab64
+ source = dpp-10.0.19.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.19.tar.gz
+ sha256sums = 1126d927540715f7405d5bc33bd7ae54314431c7b1545bb5e886addfc547cf51
pkgname = dpp
diff --git a/PKGBUILD b/PKGBUILD
index 20c04d181f55..021263adf72c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# See also https://github.com/eremiell-aur/dpp
pkgname=dpp
_pkgname=DPP
-pkgver=10.0.18
+pkgver=10.0.19
pkgrel=1
pkgdesc="Lightweight and Scalable C++ Discord API Bot Library"
arch=('x86_64')
@@ -13,7 +13,7 @@ makedepends=('cmake')
install="${pkgname}.install"
changelog="${pkgname}.changelog"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/brainboxdotcc/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('0d976673852a5d8e71833d5f6a5b9767ffaf6b6a053d8420fa921adfcb80ab64')
+sha256sums=('1126d927540715f7405d5bc33bd7ae54314431c7b1545bb5e886addfc547cf51')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
@@ -24,6 +24,7 @@ prepare() {
mv "cmake/libdpp-config.cmake" "cmake/dpp-config.cmake"
sed -i -E "s/^.*dpp\/nlohmann.*$//" "library/CMakeLists.txt"
rm -rf "include/dpp/nlohmann"
+ sed -i -E -e "s/std::map<event_handle, std::function<void\(const T\)>> coroutine_container;/std::map<event_handle, std::function<dpp::task(T)>> coroutine_container;\n#else\n \/**\n * @brief Dummy container to keep the struct size same\n *\/\n std::map<event_handle, std::function<void(T)>> dummy_container;/" -e "s/event_handle attach\(std::function<dpp::task\(const T&\)> func\) \{/event_handle co_attach(std::function<dpp::task(T)> func) {/" "include/dpp/cluster.h"
}
build() {
diff --git a/dpp.changelog b/dpp.changelog
index 13403a943e53..ed56f6fcd5c3 100644
--- a/dpp.changelog
+++ b/dpp.changelog
@@ -1,3 +1,12 @@
+# 10.0.19-1 / 2022-09-13
+
+* bump to new library version
+ * fixes more issues with reconnection
+ * see library changelog for full list
+* known issue with the coroutine code
+ * patched in the package
+ * feedback for the coroutines still wanted
+
# 10.0.18-1 / 2022-09-05
* bump to new library version
@@ -79,7 +88,7 @@
# 10.0.10-1 / 2022-06-14
* first build on the AUR
- * preceeded by a bunch of test builds and finetuning
+ * preceded by a bunch of test builds and finetuning
* consulted and collaborated with upstream
* cmake integration is semibroken as mentioned in .install
* attempts were made to narrow it down a bit
diff --git a/dpp.install b/dpp.install
index 35ee7223190c..8cf74b2472e6 100644
--- a/dpp.install
+++ b/dpp.install
@@ -18,7 +18,7 @@ post_install() {
post_upgrade() {
echo -e "\e[1;33mEmbedded fmt have been completely dropped off the package.\e[0m"
echo -e "\e[1;33mWe already replaced that by systemwide version.\e[0m"
- echo -e "\e[1;33mJust mind that it's not longer a dependency.\e[0m"
+ echo -e "\e[1;33mJust mind that it's no longer a dependency.\e[0m"
echo ""
echo -e "\e[32mPackage now includes experimental coroutine support.\e[0m"
echo -e "\e[32mIt's not considered production ready, but it's available for your experiments.\e[0m"