summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--dpp.changelog7
3 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d27b6ccf170d..c6d5ca72bbea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dpp
pkgdesc = Lightweight and Scalable C++ Discord API Bot Library
pkgver = 10.0.23
- pkgrel = 1
+ pkgrel = 2
url = https://dpp.dev/
install = dpp.install
changelog = dpp.changelog
diff --git a/PKGBUILD b/PKGBUILD
index a97973994cbd..23ad7820cf0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=dpp
_pkgname=DPP
pkgver=10.0.23
-pkgrel=1
+pkgrel=2
pkgdesc="Lightweight and Scalable C++ Discord API Bot Library"
arch=('x86_64')
url="https://dpp.dev/"
@@ -18,6 +18,7 @@ sha256sums=('8f9db61c3586a492ada378235300c509e3bc2fc090cef32de0a8241741038df0')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
rm -rf "include/dpp/nlohmann"
+ sed -i -E "s/(#pragma once)/\1\n#include <cstdint>/" "include/dpp/sslclient.h"
}
build() {
diff --git a/dpp.changelog b/dpp.changelog
index c7c46cfaaf3e..5828c7193cd2 100644
--- a/dpp.changelog
+++ b/dpp.changelog
@@ -1,3 +1,10 @@
+# 10.0.23-2 / 2023-05-16
+
+* quick patch for gcc13 compatibility
+ * one of the headers depended on transient include
+ * gcc13 broke it
+ * already fixed upstream
+
# 10.0.23-1 / 2023-03-01
* bump to new library version