summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
-rw-r--r--dpp.changelog9
3 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97b9db43049c..0736ef8d1f75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dpp
pkgdesc = Lightweight and Scalable C++ Discord API Bot Library
- pkgver = 10.0.19
+ pkgver = 10.0.20
pkgrel = 1
url = https://dpp.dev/
install = dpp.install
@@ -8,13 +8,14 @@ pkgbase = dpp
arch = x86_64
license = Apache
makedepends = cmake
+ makedepends = pkgconf
depends = gcc-libs
depends = openssl
depends = zlib
depends = opus
depends = libsodium
depends = nlohmann-json
- source = dpp-10.0.19.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.19.tar.gz
- sha256sums = 1126d927540715f7405d5bc33bd7ae54314431c7b1545bb5e886addfc547cf51
+ source = dpp-10.0.20.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.20.tar.gz
+ sha256sums = c4a7481c714c27d9c1411c668212e433fa5f6631a933676269c866295bd4ef73
pkgname = dpp
diff --git a/PKGBUILD b/PKGBUILD
index 021263adf72c..696c9b186473 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
# See also https://github.com/eremiell-aur/dpp
pkgname=dpp
_pkgname=DPP
-pkgver=10.0.19
+pkgver=10.0.20
pkgrel=1
pkgdesc="Lightweight and Scalable C++ Discord API Bot Library"
arch=('x86_64')
url="https://dpp.dev/"
license=('Apache')
depends=('gcc-libs' 'openssl' 'zlib' 'opus' 'libsodium' 'nlohmann-json')
-makedepends=('cmake')
+makedepends=('cmake' 'pkgconf')
install="${pkgname}.install"
changelog="${pkgname}.changelog"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/brainboxdotcc/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('1126d927540715f7405d5bc33bd7ae54314431c7b1545bb5e886addfc547cf51')
+sha256sums=('c4a7481c714c27d9c1411c668212e433fa5f6631a933676269c866295bd4ef73')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
@@ -24,7 +24,6 @@ prepare() {
mv "cmake/libdpp-config.cmake" "cmake/dpp-config.cmake"
sed -i -E "s/^.*dpp\/nlohmann.*$//" "library/CMakeLists.txt"
rm -rf "include/dpp/nlohmann"
- sed -i -E -e "s/std::map<event_handle, std::function<void\(const T\)>> coroutine_container;/std::map<event_handle, std::function<dpp::task(T)>> coroutine_container;\n#else\n \/**\n * @brief Dummy container to keep the struct size same\n *\/\n std::map<event_handle, std::function<void(T)>> dummy_container;/" -e "s/event_handle attach\(std::function<dpp::task\(const T&\)> func\) \{/event_handle co_attach(std::function<dpp::task(T)> func) {/" "include/dpp/cluster.h"
}
build() {
diff --git a/dpp.changelog b/dpp.changelog
index ed56f6fcd5c3..aa240af16237 100644
--- a/dpp.changelog
+++ b/dpp.changelog
@@ -1,3 +1,12 @@
+# 10.0.20-1 / 2022-09-30
+
+* bump to new library version
+ * forums support
+ * see library changelog for full list
+* pkgconf now a makedep
+ * has been causing some issues with sodium
+* patch for the coroutines from last version upstreamed
+
# 10.0.19-1 / 2022-09-13
* bump to new library version