summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
-rw-r--r--dpp.changelog11
-rw-r--r--dpp.install7
4 files changed, 20 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0736ef8d1f75..991ac7b3ba7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dpp
pkgdesc = Lightweight and Scalable C++ Discord API Bot Library
- pkgver = 10.0.20
+ pkgver = 10.0.21
pkgrel = 1
url = https://dpp.dev/
install = dpp.install
@@ -15,7 +15,7 @@ pkgbase = dpp
depends = opus
depends = libsodium
depends = nlohmann-json
- source = dpp-10.0.20.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.20.tar.gz
- sha256sums = c4a7481c714c27d9c1411c668212e433fa5f6631a933676269c866295bd4ef73
+ source = dpp-10.0.21.tar.gz::https://github.com/brainboxdotcc/DPP/archive/refs/tags/v10.0.21.tar.gz
+ sha256sums = 8ef2bb75f16b80d742a99c3a18ab5a2a57bce74238518af9b9aca670c2d7034b
pkgname = dpp
diff --git a/PKGBUILD b/PKGBUILD
index 696c9b186473..f171d7701b3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# See also https://github.com/eremiell-aur/dpp
pkgname=dpp
_pkgname=DPP
-pkgver=10.0.20
+pkgver=10.0.21
pkgrel=1
pkgdesc="Lightweight and Scalable C++ Discord API Bot Library"
arch=('x86_64')
@@ -13,7 +13,7 @@ makedepends=('cmake' 'pkgconf')
install="${pkgname}.install"
changelog="${pkgname}.changelog"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/brainboxdotcc/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('c4a7481c714c27d9c1411c668212e433fa5f6631a933676269c866295bd4ef73')
+sha256sums=('8ef2bb75f16b80d742a99c3a18ab5a2a57bce74238518af9b9aca670c2d7034b')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
@@ -44,4 +44,5 @@ package() {
find "${pkgdir}" -iname "*.cmake" -exec sed -i -E "s/\/dpp-${pkgver%.*}//g" '{}' \+
sed -i -E "s/if\(_realCurr STREQUAL _realOrig\)/if\(1\)/" "${pkgdir}/usr/lib/cmake/dpp/dpp.cmake" "${pkgdir}/usr/lib/cmake/dpp/dpp-targets.cmake"
sed -i -E "s/([ \(_]dpp)/\1::dpp/" "${pkgdir}/usr/lib/cmake/dpp/dpp-targets-noconfig.cmake"
+ ln -s "/usr/include/nlohmann" "${pkgdir}/usr/include/dpp/nlohmann"
}
diff --git a/dpp.changelog b/dpp.changelog
index aa240af16237..78198bbf6a57 100644
--- a/dpp.changelog
+++ b/dpp.changelog
@@ -1,3 +1,14 @@
+# 10.0.21-1 / 2022-11-02
+
+* bump to new library version
+ * support for various new small Discord features
+ * fixes for several race conditions and other stuff
+ * see library changelog for full list
+* symlink is now provided in place of the embedded nlohmann/json
+ * package still uses systemwide packaged version
+ * helps easier adoption of online tutorials and similar resources
+ * helps with compatibility with other installations
+
# 10.0.20-1 / 2022-09-30
* bump to new library version
diff --git a/dpp.install b/dpp.install
index 8cf74b2472e6..2e3baadd422e 100644
--- a/dpp.install
+++ b/dpp.install
@@ -8,7 +8,7 @@ post_install() {
echo ""
echo -e "\e[32mTo keep things lean and clean, embedded nlohmann/json have been replaced by\e[0m"
echo -e "\e[32mpackaged version.\e[0m"
- echo -e "\e[32mMind that when looking up online tutorials.\e[0m"
+ echo -e "\e[32mSymlink has been provided for convenience, but you may prefer to use it directly.\e[0m"
echo ""
echo -e "\e[32mPackage now includes experimental coroutine support.\e[0m"
echo -e "\e[32mIt's not considered production ready, but it's available for your experiments.\e[0m"
@@ -16,9 +16,8 @@ post_install() {
}
post_upgrade() {
- echo -e "\e[1;33mEmbedded fmt have been completely dropped off the package.\e[0m"
- echo -e "\e[1;33mWe already replaced that by systemwide version.\e[0m"
- echo -e "\e[1;33mJust mind that it's no longer a dependency.\e[0m"
+ echo -e "\e[1;33mSymlink has been provided for the embedded nlohmann/json library.\e[0m"
+ echo -e "\e[1;33mWe keep using the systemwide version. It's just for easier use of online tutorials.\e[0m"
echo ""
echo -e "\e[32mPackage now includes experimental coroutine support.\e[0m"
echo -e "\e[32mIt's not considered production ready, but it's available for your experiments.\e[0m"