summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--LICENSE (renamed from LICENSE.md)4
-rw-r--r--PKGBUILD31
3 files changed, 22 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae910aa2728d..459b4759beb2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = dprint-bin
pkgdesc = Pluggable and configurable code formatting platform written in Rust.
pkgver = 0.23.1
- pkgrel = 2
- url = https://dprint.dev/
+ pkgrel = 3
+ url = https://github.com/dprint/dprint
arch = x86_64
license = MIT
+ depends = gcc-libs
provides = dprint
conflicts = dprint
- source = 0.23.1.zip::https://github.com/dprint/dprint/releases/download/0.23.1/dprint-x86_64-unknown-linux-gnu.zip
- source = 0.23.1.LICENSE::https://github.com/dprint/dprint/raw/0.23.1/LICENSE
+ source = dprint-bin-0.23.1.zip::https://github.com/dprint/dprint/releases/download/0.23.1/dprint-x86_64-unknown-linux-gnu.zip
+ source = LICENSE
sha256sums = c57923a76ce8b5b134371f337db437a59b4ea5a86875c55339d366ad409bfd2a
- sha256sums = SKIP
+ sha256sums = 43f8cfbeca17eccd83fc98f27d211073eaee5574fc3162f345acc196d6190ce7
pkgname = dprint-bin
diff --git a/LICENSE.md b/LICENSE
index 74e2787c5da8..84542ab9eca4 100644
--- a/LICENSE.md
+++ b/LICENSE
@@ -1,6 +1,6 @@
-# The MIT License
+The MIT License (MIT)
-Copyright © 2020 Hoàng Văn Khải
+Copyright (c) 2019-2022 David Sherret
Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
diff --git a/PKGBUILD b/PKGBUILD
index ea99921a7f47..c64f3975c550 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,22 @@
-# Maintainer: Hoàng Văn Khải <hvksmr1996@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Hoàng Văn Khải <hvksmr1996@gmail.com>
-pkgname='dprint-bin'
-pkgver='0.23.1'
-pkgrel='2'
+pkgname=dprint-bin
+pkgver=0.23.1
+pkgrel=3
pkgdesc='Pluggable and configurable code formatting platform written in Rust.'
arch=('x86_64')
-url='https://dprint.dev/'
+url='https://github.com/dprint/dprint'
license=('MIT')
-conflicts=('dprint')
+depends=('gcc-libs')
provides=('dprint')
-_repo='https://github.com/dprint/dprint'
-source=(
- "$pkgver.zip::$_repo/releases/download/$pkgver/dprint-x86_64-unknown-linux-gnu.zip"
- "$pkgver.LICENSE::$_repo/raw/$pkgver/LICENSE"
-)
-sha256sums=(
- 'c57923a76ce8b5b134371f337db437a59b4ea5a86875c55339d366ad409bfd2a'
- 'SKIP'
-)
+conflicts=('dprint')
+source=("$pkgname-$pkgver.zip::$url/releases/download/$pkgver/dprint-x86_64-unknown-linux-gnu.zip"
+ 'LICENSE')
+sha256sums=('c57923a76ce8b5b134371f337db437a59b4ea5a86875c55339d366ad409bfd2a'
+ '43f8cfbeca17eccd83fc98f27d211073eaee5574fc3162f345acc196d6190ce7')
package() {
- install -Dm755 dprint "$pkgdir/usr/bin/dprint"
- install -Dm644 "$pkgver.LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D dprint -t "$pkgdir/usr/bin/"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}