summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--pyxdg-compatibility.patch14
3 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3618f167f810..485179081854 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dput
pkgdesc = Debian package upload tool
- pkgver = 1.1.2
- pkgrel = 4
+ pkgver = 1.1.3
+ pkgrel = 1
url = http://packages.qa.debian.org/dput
arch = any
license = GPL
@@ -10,9 +10,9 @@ pkgbase = dput
depends = python-debian
depends = python-gpgme
depends = python-pyxdg
- source = http://http.debian.net/debian/pool/main/d/dput/dput_1.1.2.tar.xz
+ source = http://http.debian.net/debian/pool/main/d/dput/dput_1.1.3.tar.xz
source = pyxdg-compatibility.patch
- sha256sums = cfdf60ab70806095b90dd6b266c9e397b30b2a8ac69e3660e4cb70db18636432
- sha256sums = 2e19cb96d405f25b42ff2e4b1ac4651e4c6a6f96693d200170a8f69f55b33117
+ sha256sums = ef92187cc843b9703b4fb94b5c06a31399ff714ba7ebbcc637358757613fede2
+ sha256sums = a6d350af5eba4cf5b5d3cd9e784a77f0a7b3b5fcdacd304245713c1a85540abf
pkgname = dput
diff --git a/PKGBUILD b/PKGBUILD
index 2847e7efac19..8f5590c29b0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Jan Dolinar <dolik.rce@gmail.com>
# Contributor: Andre Klitzing <andre () incubo () de>
pkgname=dput
-pkgver=1.1.2
-pkgrel=4
+pkgver=1.1.3
+pkgrel=1
pkgdesc="Debian package upload tool"
arch=('any')
url="http://packages.qa.debian.org/dput"
@@ -14,8 +14,8 @@ source=(
http://http.debian.net/debian/pool/main/d/${pkgname}/${pkgname}_${pkgver}.tar.xz
pyxdg-compatibility.patch
)
-sha256sums=('cfdf60ab70806095b90dd6b266c9e397b30b2a8ac69e3660e4cb70db18636432'
- '2e19cb96d405f25b42ff2e4b1ac4651e4c6a6f96693d200170a8f69f55b33117')
+sha256sums=('ef92187cc843b9703b4fb94b5c06a31399ff714ba7ebbcc637358757613fede2'
+ 'a6d350af5eba4cf5b5d3cd9e784a77f0a7b3b5fcdacd304245713c1a85540abf')
prepare() {
cd "$pkgname-$pkgver"
diff --git a/pyxdg-compatibility.patch b/pyxdg-compatibility.patch
index d64f96bea5be..ccce6334ffd6 100644
--- a/pyxdg-compatibility.patch
+++ b/pyxdg-compatibility.patch
@@ -8,13 +8,13 @@ diff -rU2 dput.orig/dput/configfile.py dput/dput/configfile.py
+from xdg import BaseDirectory
-@@ -44,5 +44,5 @@
- ('global', os.path.join(os.path.sep, 'etc', 'dput.cf')),
- ('user_xdg', os.path.join(
-- xdg.xdg_config_home(), 'dput', 'dput.cf')),
-+ BaseDirectory.xdg_config_home, 'dput', 'dput.cf')),
- ('user_home', os.path.join(
- os.path.expanduser('~'), '.dput.cf')),
+@@ -23,5 +23,5 @@
+ ('global', os.path.join(os.path.sep, "etc", "dput.cf")),
+ ('user_xdg', os.path.join(
+- xdg.xdg_config_home(), "dput", "dput.cf")),
++ BaseDirectory.xdg_config_home, 'dput', 'dput.cf')),
+ ('user_home', os.path.join(
+ os.path.expanduser("~"), ".dput.cf")),
diff -rU2 dput.orig/setup.py dput/setup.py
--- dput.orig/setup.py 2022-07-01 15:15:28.000000000 -0700
+++ dput/setup.py 2022-10-27 10:36:34.862581758 -0700