summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 82d79b976675..1ced330d7383 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,6 +20,11 @@ prepare() {
bsdtar -xf "../drawio-desktop-$pkgver.zip" -C .
rm -rf "META-INF" "WEB-INF"
+
+ # disable updater
+ sed -e '/electron-updater/d' -i 'package.json'
+ local updater='const autoUpdater = { on: () => {}, setFeedURL: () => {}, checkForUpdates: () => {} }'
+ sed -e 's/.*require("electron-updater").*/'"$updater"'/' -e '/checkForUpdates,/d' -i 'electron.js'
}
build() {