summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--.gitlab-ci.yml17
-rw-r--r--PKGBUILD1
3 files changed, 19 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8cdd145e5f2..7d78529aa441 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = drawio-desktop-bin
depends = gtk3
depends = libxss
depends = nss
+ depends = alsa-lib
provides = drawio-desktop
conflicts = drawio-desktop
source = drawio-desktop-bin-24.2.5.deb::https://github.com/jgraph/drawio-desktop/releases/download/v24.2.5/drawio-amd64-24.2.5.deb
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 7d4de61acfb7..c7505c29080f 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -21,6 +21,23 @@ build:
paths:
- '*.pkg.tar.zst'
+test:
+ stage: test
+ image:
+ name: countstarlight/makepkg:latest
+ entrypoint: [""]
+ before_script:
+ - sudo pacman -Sy --noconfirm archlinux-keyring
+ - yay -Syu --noconfirm
+ - yay -Sy --noconfirm xorg-server-xvfb
+ - |
+ depends=()
+ . ./PKGBUILD
+ (pacman --deptest "${depends[@]}" || true) | xargs yay -Sy --noconfirm
+ script:
+ - yay --noconfirm -U *.pkg.tar.zst
+ - xvfb-run drawio -V
+
deploy:
stage: deploy
image: bitnami/git:latest
diff --git a/PKGBUILD b/PKGBUILD
index e0e869b44707..d8cf4e8cc43c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,6 +11,7 @@ depends=(
"gtk3"
"libxss"
"nss"
+ "alsa-lib"
)
provides=('drawio-desktop')
conflicts=('drawio-desktop')