summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD26
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ef37dd02615
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = dream
+ pkgdesc = A software radio for AM and Digital Radio Mondiale (DRM)
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = https://sourceforge.net/projects/drm
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = gcc
+ depends = fftw
+ depends = opus
+ depends = libsndfile
+ depends = speexdsp
+ depends = hamlib
+ depends = libpulse
+ depends = qwt
+ depends = qt5-webkit
+ depends = qt5-svg
+ depends = qt5-base
+ source = https://sourceforge.net/projects/drm/files/dream/2.1.1/dream-2.1.1-svn808.tar.gz
+ md5sums = 4745a4f03216bc3afda077398d0e5d3b
+
+pkgname = dream
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7df83007a82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+pkgname=dream
+pkgver=2.1.1
+pkgrel=1
+pkgdesc="A software radio for AM and Digital Radio Mondiale (DRM)"
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/drm"
+license=(GPL2)
+depends=(fftw opus libsndfile speexdsp hamlib libpulse qwt qt5-webkit qt5-svg qt5-base)
+makedepends=(gcc)
+source=("https://sourceforge.net/projects/drm/files/dream/${pkgver}/${pkgname}-${pkgver}-svn808.tar.gz")
+md5sums=('4745a4f03216bc3afda077398d0e5d3b')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ qmake-qt5 dream.pro
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ make INSTALL_ROOT=${pkgdir} install
+}