summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 812264e73087..da2239b04be2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Fri Oct 23 04:08:38 UTC 2015
pkgbase = drive-git
pkgdesc = Drive is a tiny program to pull or push Google Drive files. You need go1.2 installed in order to build the program.
- pkgver = r369.a4cfe9a
+ pkgver = r587.6cb2970
pkgrel = 1
url = https://github.com/odeke-em/drive
install = drive-git.install
diff --git a/PKGBUILD b/PKGBUILD
index a8da86f4f6a1..a5fbe7c9882b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Timofey Titovets <nefelim4ag@gmail.com>
pkgname=drive-git
-pkgver=r369.a4cfe9a
+pkgver=r587.6cb2970
pkgrel=1
pkgdesc="Drive is a tiny program to pull or push Google Drive files. You need go1.2 installed in order to build the program."
arch=('any')
@@ -26,11 +26,16 @@ build() {
go get $_gourl
cd $srcdir/bin/
./drive-gen
+ go get github.com/odeke-em/rsc/qr
+ go get github.com/martini-contrib/binding
+ cd $srcdir/$pkgname/drive-server
+ go build -o drive-server
}
package() {
mkdir -p "$pkgdir/usr/bin"
install -p -m755 $srcdir/bin/drive "$pkgdir/usr/bin"
+ install -p -m755 $srcdir/$pkgname/drive-server/drive-server "$pkgdir/usr/bin"
cd "$srcdir/$pkgname"
mkdir -p $pkgdir/usr/share/licenses/$pkgname