summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD36
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1affb6cc5766
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = drumstick-svn
+ pkgdesc = MIDI libraries for Qt5/C++. (SVN version)
+ pkgver = 20170510.341
+ pkgrel = 1
+ url = http://drumstick.sourceforge.net
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = cmake
+ makedepends = doxygen
+ makedepends = docbook-xsl
+ makedepends = subversion
+ depends = fluidsynth
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = shared-mime-info
+ depends = qt5-svg
+ provides = drumstick
+ conflicts = drumstick
+ source = svn+https://svn.code.sf.net/p/drumstick/code/trunk
+ sha256sums = SKIP
+
+pkgname = drumstick-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0f53e472570
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Konstantinos Foutzopoulos <mail@konfou.xyz>
+
+_pkgname=drumstick
+pkgname=${_pkgname}-svn
+pkgver=20170510.341
+pkgrel=1
+pkgdesc="MIDI libraries for Qt5/C++. (SVN version)"
+arch=('x86_64' 'i686')
+url="http://drumstick.sourceforge.net"
+license=('GPL')
+depends=('fluidsynth' 'desktop-file-utils' 'hicolor-icon-theme' 'shared-mime-info' 'qt5-svg')
+makedepends=('cmake' 'doxygen' 'docbook-xsl' 'subversion')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("svn+https://svn.code.sf.net/p/${_pkgname}/code/trunk")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd trunk
+ svn info | awk '/Revision/{r=$2}/Date/{gsub(/-/,"");d=$4}END{print d"."r}'
+}
+
+build() {
+ cd trunk
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=release \
+ -DLIB_SUFFIX=
+ make
+}
+
+package() {
+ cd trunk
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: