summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9977f9ff863f..83e8155fae42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Jan 16 13:09:06 UTC 2016
+# Sat Jan 16 13:31:35 UTC 2016
pkgbase = drush-git-alternative
pkgdesc = Drush is a command line shell and Unix scripting interface for Drupal
pkgver = 8.0.2.r14.g30f88b2
@@ -13,7 +13,7 @@ pkgbase = drush-git-alternative
depends = php
provides = drush=8.0.2.r14.g30f88b2
conflicts = drush
- source = drush::git+https://github.com/drush-ops/drush.git
+ source = drush-8.0.2.r14.g30f88b2::git+https://github.com/drush-ops/drush.git
sha512sums = SKIP
pkgname = drush-git-alternative
diff --git a/PKGBUILD b/PKGBUILD
index 4be78d207b0c..8702015831a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ depends=('php')
makedepends=("php-box" "php-composer" "git")
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
-source=("${_pkgname}"::"git+https://github.com/drush-ops/drush.git")
+source=("${_pkgname}-${pkgver}"::"git+https://github.com/drush-ops/drush.git")
sha512sums=('SKIP')
pkgver() {
@@ -21,16 +21,16 @@ pkgver() {
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
php /usr/bin/composer install --no-dev
cp box.json.dist box.json
php -d phar.readonly=Off /usr/bin/php-box build
}
package() {
- cd "${_pkgname}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
install -D -m755 "${_pkgname}.phar" "${pkgdir}/usr/bin/${_pkgname}"
- install -m644 "examples/example.aliases.drushrc.php" "${pkgdir}/etc/drush/aliases.drushrc.php"
- install -m644 "examples/example.drush.ini" "${pkgdir}/etc/drush/drush.ini"
- install -m644 "examples/example.drushrc.php" "${pkgdir}/etc/drush/drushrc.php"
+ install -D -m644 "examples/example.aliases.drushrc.php" "${pkgdir}/etc/drush/aliases.drushrc.php"
+ install -D -m644 "examples/example.drush.ini" "${pkgdir}/etc/drush/drush.ini"
+ install -D -m644 "examples/example.drushrc.php" "${pkgdir}/etc/drush/drushrc.php"
}