summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore27
-rw-r--r--PKGBUILD24
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51db02221548
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = drush-scaffolding
+ pkgdesc = A Drush command to fetch assorted site building and development modules to enable and configure.
+ pkgver = 7.x_1.0
+ pkgrel = 1
+ url = https://www.drupal.org/project/scaffolding
+ arch = any
+ license = GPL
+ makedepends = drupal
+ depends = drush
+ provides = scaffolding=7.x_1.0
+ conflicts = scaffolding
+ source = https://ftp.drupal.org/files/projects/scaffolding-7.x-1.0.tar.gz
+ md5sums = f637f7b917888beed096914f98497aef
+
+pkgname = drush-scaffolding
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..43316bc3c124
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# makepkg working folders
+pkg
+src
+
+#
+# Additional ignore patterns:
+#
+
+# Source files
+*.deb
+*.gem
+*.out
+*.rpm
+*.html
+
+# Ignore package source folders
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..daf797c492ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: James An <james@jamesan.ca>
+
+pkgname=drush-scaffolding
+_pkgname=${pkgname#drush-}
+pkgver=7.x_1.0
+pkgrel=1
+pkgdesc="A Drush command to fetch assorted site building and development modules to enable and configure."
+arch=('any')
+url="https://www.drupal.org/project/$_pkgname"
+license=('GPL')
+depends=('drush')
+makedepends=('drupal')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+options=()
+install=
+source=("https://ftp.drupal.org/files/projects/$_pkgname-${pkgver//_/-}.tar.gz")
+md5sums=('f637f7b917888beed096914f98497aef')
+
+package() {
+ cd "$_pkgname"
+
+ install -Dm755 scaffold.drush.inc "$pkgdir/usr/share/webapps/drush/commands/$_pkgname/scaffold.drush.inc"
+}