summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
-rw-r--r--format-security.patch81
3 files changed, 100 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7acd41215566..266d8c5ef2ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,25 @@
pkgbase = ds9
pkgdesc = SAOImage DS9: Astronomical Data Visualization Application
- pkgver = 8.2.1
+ pkgver = 8.3
pkgrel = 1
url = http://hea-www.harvard.edu/RD/ds9/
arch = x86_64
license = GPL2
makedepends = libx11
- makedepends = libxml2
makedepends = libxslt
- makedepends = libpng
+ makedepends = libxml2
+ makedepends = libxft
makedepends = tcl
makedepends = zip
provides = ds9
options = !strip
- source = https://github.com/SAOImageDS9/SAOImageDS9/archive/v8.2.1.tar.gz
+ source = https://github.com/SAOImageDS9/SAOImageDS9/archive/v8.3.tar.gz
source = ds9.desktop
source = ds9.png
- md5sums = fdac9f96738a83f823a61e3ec887676f
+ source = format-security.patch
+ md5sums = 1c3784c93d63ee1c194b0480f17d3f93
md5sums = f1738e4ec665ae9afd1b65b86e6a07f1
md5sums = 9297d5738f5f462831075c483dc785d5
+ md5sums = 64ebd4c1e03b45fc682b692046028f1d
pkgname = ds9
-
diff --git a/PKGBUILD b/PKGBUILD
index 95f3b3aaeb03..a0d926b890d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Yigit Dallilar <yigit.dallilar at gmail dot com>
pkgname=ds9
-pkgver=8.2.1
+pkgver=8.3
pkgrel=1
pkgdesc="SAOImage DS9: Astronomical Data Visualization Application"
url="http://hea-www.harvard.edu/RD/ds9/"
@@ -11,18 +11,25 @@ provides=(ds9)
conflicts=(ds9-bin)
depends=()
options=(!strip)
-makedepends=(libx11 libxml2 libxslt libpng tcl zip)
+makedepends=(libx11 libxslt libxml2 libxft tcl zip)
conflicts=()
replaces=()
backup=()
source=("https://github.com/SAOImageDS9/SAOImageDS9/archive/v${pkgver}.tar.gz"
"ds9.desktop"
- "ds9.png")
-md5sums=('fdac9f96738a83f823a61e3ec887676f'
+ "ds9.png"
+ "format-security.patch")
+md5sums=('1c3784c93d63ee1c194b0480f17d3f93'
'f1738e4ec665ae9afd1b65b86e6a07f1'
- '9297d5738f5f462831075c483dc785d5')
+ '9297d5738f5f462831075c483dc785d5'
+ '64ebd4c1e03b45fc682b692046028f1d')
+prepare() {
+ cd ${srcdir}/SAOImageDS9-${pkgver}
+ patch --strip=1 < ../format-security.patch
+}
+
build() {
cd ${srcdir}/SAOImageDS9-${pkgver}
unix/configure
diff --git a/format-security.patch b/format-security.patch
new file mode 100644
index 000000000000..cbbf5152de74
--- /dev/null
+++ b/format-security.patch
@@ -0,0 +1,81 @@
+diff --unified --recursive --text SAOImageDS9-8.2.1.orig/tksao/colorbar/cbgrid.C SAOImageDS9-8.2.1.new/tksao/colorbar/cbgrid.C
+--- SAOImageDS9-8.2.1.orig/tksao/colorbar/cbgrid.C 2021-01-12 19:17:40.000000000 +0100
++++ SAOImageDS9-8.2.1.new/tksao/colorbar/cbgrid.C 2021-11-09 14:07:24.833647694 +0100
+@@ -197,7 +197,7 @@
+ pbox[3] = 0;
+ }
+
+- plot = astPlot(frameSet, gbox, pbox, option_);
++ plot = astPlot(frameSet, gbox, pbox, option_, "");
+
+ // and now create astGrid
+ astGrid2dPtr = this;
+diff --unified --recursive --text SAOImageDS9-8.2.1.orig/tksao/frame/grid25d.C SAOImageDS9-8.2.1.new/tksao/frame/grid25d.C
+--- SAOImageDS9-8.2.1.orig/tksao/frame/grid25d.C 2021-01-12 19:17:40.000000000 +0100
++++ SAOImageDS9-8.2.1.new/tksao/frame/grid25d.C 2021-11-09 14:28:49.727020650 +0100
+@@ -142,7 +142,7 @@
+ // and now create astGrid
+ astGrid25dPtr = this;
+
+- AstPlot* plot = astPlot(frameSet, gbox, pbox, option_);
++ AstPlot* plot = astPlot(frameSet, gbox, pbox, option_, "");
+ astGrid(plot);
+
+ astEnd; // now, clean up memory
+@@ -159,5 +159,5 @@
+ AstShiftMap* sm = astShiftMap(2, tt, "");
+ AstCmpMap* cmp = astCmpMap(mm, sm, 1, "");
+
+- astAddFrame((AstFrameSet*)frameSet, AST__CURRENT, cmp, astFrame(2, str));
++ astAddFrame((AstFrameSet*)frameSet, AST__CURRENT, cmp, astFrame(2, str, ""));
+ }
+diff --unified --recursive --text SAOImageDS9-8.2.1.orig/tksao/frame/grid2d.C SAOImageDS9-8.2.1.new/tksao/frame/grid2d.C
+--- SAOImageDS9-8.2.1.orig/tksao/frame/grid2d.C 2021-01-12 19:17:40.000000000 +0100
++++ SAOImageDS9-8.2.1.new/tksao/frame/grid2d.C 2021-11-09 14:29:26.573688468 +0100
+@@ -164,7 +164,7 @@
+ // and now create astGrid
+ astGrid2dPtr = this;
+
+- AstPlot* plot = astPlot(frameSet, gbox, pbox, option_);
++ AstPlot* plot = astPlot(frameSet, gbox, pbox, option_, "");
+ astGrid(plot);
+
+ astEnd; // now, clean up memory
+@@ -181,5 +181,5 @@
+ AstShiftMap* sm = astShiftMap(2, tt, "");
+ AstCmpMap* cmp = astCmpMap(mm, sm, 1, "");
+
+- astAddFrame((AstFrameSet*)frameSet, AST__CURRENT, cmp, astFrame(2, str));
++ astAddFrame((AstFrameSet*)frameSet, AST__CURRENT, cmp, astFrame(2, str, ""));
+ }
+diff --unified --recursive --text SAOImageDS9-8.2.1.orig/tksao/frame/grid3d.C SAOImageDS9-8.2.1.new/tksao/frame/grid3d.C
+--- SAOImageDS9-8.2.1.orig/tksao/frame/grid3d.C 2021-01-12 19:17:40.000000000 +0100
++++ SAOImageDS9-8.2.1.new/tksao/frame/grid3d.C 2021-11-09 14:29:57.260356085 +0100
+@@ -163,7 +163,7 @@
+ astGrid3dPtr = this;
+ renderMode_ = rm;
+
+- AstPlot3D* plot = astPlot3D(frameSet, gbox, pbox, option_);
++ AstPlot3D* plot = astPlot3D(frameSet, gbox, pbox, option_, "");
+ astGrid(plot);
+
+ astEnd; // now, clean up memory
+@@ -181,5 +181,5 @@
+ AstShiftMap* sm = astShiftMap(3,tt,"");
+ AstCmpMap* cmp = astCmpMap(mm,sm,1,"");
+
+- astAddFrame((AstFrameSet*)frameSet, AST__CURRENT, cmp, astFrame(3, str));
++ astAddFrame((AstFrameSet*)frameSet, AST__CURRENT, cmp, astFrame(3, str, ""));
+ }
+diff --unified --recursive --text SAOImageDS9-8.2.1.orig/tksao/frame/wcsast.C SAOImageDS9-8.2.1.new/tksao/frame/wcsast.C
+--- SAOImageDS9-8.2.1.orig/tksao/frame/wcsast.C 2021-01-12 19:17:40.000000000 +0100
++++ SAOImageDS9-8.2.1.new/tksao/frame/wcsast.C 2021-11-09 14:32:29.410360780 +0100
+@@ -63,7 +63,7 @@
+ }
+ ostringstream str;
+ str << "Format(" << id << ")=" << format << ends;
+- astSet(ast, str.str().c_str());
++ astSet(ast, str.str().c_str(), "");
+ }
+
+ Vector wcsTran(Context* context, AstFrameSet* ast,