summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD42
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c995d5a7a575
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 5.0.1
+# Wed Mar 30 17:00:13 UTC 2016
+pkgbase = dspatch
+ pkgdesc = A powerful C++ flow-based programming library that allows you to create and route (or "patch") high performance data processing circuits.
+ pkgver = 3.00
+ pkgrel = 1
+ url = http://flowbasedprogramming.com/DSPatch/index.html
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake,
+ makedepends = gcc
+ depends = glibc
+ source = http://netix.dl.sourceforge.net/project/dspatch/DSPatch-3.00.zip
+ md5sums = eea62d626b1736fc983e33f717c12475
+
+pkgname = dspatch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c07fa348c20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Johannes "hpfmn" Wegener <mail@johanneswegener.de>
+pkgname=dspatch
+pkgver=3.00
+pkgrel=1
+epoch=
+pkgdesc="A powerful C++ flow-based programming library that allows you to create and route (or \"patch\") high performance data processing circuits."
+arch=("x86_64")
+url="http://flowbasedprogramming.com/DSPatch/index.html"
+license=('LGPL')
+groups=()
+depends=('glibc')
+makedepends=('cmake', 'gcc')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("http://netix.dl.sourceforge.net/project/dspatch/DSPatch-$pkgver.zip")
+noextract=()
+md5sums=('eea62d626b1736fc983e33f717c12475')
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname"
+ mkdir -p build
+}
+
+build() {
+ cd "$pkgname"
+ cd build
+ cmake ../ -DCMAKE_INSTALL_PREFIX=/usr -G "Unix Makefiles"
+ make
+}
+
+package() {
+ cd "$pkgname/build"
+ make DESTDIR="$pkgdir/" install
+}