summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD22
1 files changed, 6 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a3319f99ee00..f359fda6eea0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,28 @@
# Maintainer: Dicebot <public@dicebot.lv>
pkgname=dstep
-pkgver=0.1.0
-pkgrel=2
+pkgver=0.2.2
+pkgrel=1
pkgdesc="Automatic C header to D module translator"
arch=('i686' 'x86_64')
groups=('dlang')
url="https://github.com/jacob-carlborg/dstep"
license=('custom')
-depends=('clang')
-makedepends=('git' 'd-compiler' 'd-stdlib' 'dtools')
+depends=('clang' 'liblphobos')
+makedepends=('git' 'dub' 'ldc' 'liblphobos')
source=(
"git+https://github.com/jacob-carlborg/dstep.git#tag=v$pkgver"
- "tango::git+https://github.com/SiegeLord/Tango-D2.git"
- "git+https://github.com/Dicebot/Arch-PKGBUILDs.git"
"http://www.boost.org/LICENSE_1_0.txt"
)
sha1sums=(
'SKIP'
- 'SKIP'
- 'SKIP'
'3cba29011be2b9d59f6204d6fa0a386b1b2dbd90'
)
build ()
{
- DMD=`$srcdir/Arch-PKGBUILDs/d-compiler.sh`
-
- cd $srcdir/tango
- make -f build/Makefile DC=$DMD ARCH=$CARCH COMPILER=$(basedir $DMD)
- mv libtango-* libtango.a
-
cd $srcdir/dstep
- git submodule update --init --recursive
- rdmd --compiler=$DMD --build-only -debug -gc -ofbin/dstep -Idstack/mambo -Idstack -I$srcdir/tango -L-L$srcdir/tango -I/usr/include/dlang -L-lclang -L-ltango dstep/driver/DStep.d
+ dub upgrade
+ dub build
}
package ()