summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD49
-rw-r--r--third_arg.patch17
3 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee1d19385ba9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = dtrace-utils
+ pkgdesc = DTrace-utils contains the Userspace portion of the DTrace port to Linux
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/oracle/dtrace-utils
+ arch = x86_64
+ license = UPL
+ makedepends = glibc
+ makedepends = flex
+ makedepends = bison
+ makedepends = libelf
+ makedepends = kernel-uek-devel
+ makedepends = dtrace-utils-devel
+ depends = elfutils
+ depends = zlib
+ depends = sudo
+ depends = git
+ source = https://github.com/oracle/dtrace-utils/archive/1.0.2.tar.gz
+ source = third_arg.patch
+ md5sums = c344a52504d1124b2e2188dda344b43e
+ md5sums = 48b69bae8daf29415f45c3a22c3f4d7f
+
+pkgname = dtrace-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00136c99c40c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Bailey Kasin <bailey@gingertechnology.net>
+
+pkgname=dtrace-utils
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="DTrace-utils contains the Userspace portion of the DTrace port to Linux"
+arch=('x86_64')
+url="https://github.com/oracle/dtrace-utils"
+license=('UPL')
+depends=(
+ 'elfutils'
+ 'zlib'
+ 'sudo'
+ 'git'
+)
+makedepends=(
+ 'glibc'
+ 'flex'
+ 'bison'
+ 'libelf'
+ 'kernel-uek-devel'
+ 'dtrace-utils-devel'
+)
+source=(
+ 'https://github.com/oracle/dtrace-utils/archive/1.0.2.tar.gz'
+ 'third_arg.patch'
+)
+md5sums=(
+ 'c344a52504d1124b2e2188dda344b43e'
+ '48b69bae8daf29415f45c3a22c3f4d7f'
+)
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -p0 < "${srcdir}/third_arg.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir ../linux
+ cp -r /usr/src/kernels/4.14.35-1818.0.9.el7uek.x86_64/include/uapi/linux/dtrace ../linux/
+ make HDRPREFIX=../
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ sudo make install
+}
diff --git a/third_arg.patch b/third_arg.patch
new file mode 100644
index 000000000000..89d35e0bac21
--- /dev/null
+++ b/third_arg.patch
@@ -0,0 +1,17 @@
+--- test/triggers/bogus-ioctl.c 2018-07-31 00:22:00.876656446 -0700
++++ test/triggers/bogus-ioctl-fix.c 2018-07-31 00:22:40.804948000 -0700
+@@ -58,12 +58,12 @@
+ * pathname and properties) using various flags and seek offsets.
+ */
+ fds[n++] = open(file, O_RDONLY);
+- fds[n++] = open(file, O_WRONLY);
++ fds[n++] = open(file, O_WRONLY, 0600);
+ fds[n++] = open(file, O_RDWR);
+
+ fds[n++] = open(file, O_RDWR | O_APPEND | O_CREAT | O_DSYNC |
+ O_LARGEFILE | O_NOCTTY | O_NONBLOCK | O_NDELAY | O_RSYNC |
+- O_SYNC | O_TRUNC);
++ O_SYNC | O_TRUNC, 0600);
+
+ fds[n++] = open(file, O_RDWR);
+ (void) lseek(fds[n - 1], 123, SEEK_SET);